ERRORE : 32 - bit binari emulatore Linux Android sono obsoleti

? user242918 @ | Original: StackOverFlow

Ho installato l'ultima versione del bit ADT Bundle 32 sulla mia ubuntu 14.04 32 bit . Ho creato un AVD, ma non si avvia . Quando si preme il pulsante di avvio mostra questo messaggio :

Avvio di emulatore per AVD ' NexusOne ' ERRORE : binari emulatore Linux Android a 32 bit sono obsoleti, di usarli        si dovrà fare almeno una delle seguenti :        - Utilizzare l'opzione ' force - 32bit ' quando si invoca ' emulatore ' .        - Set ANDROID_EMULATOR_FORCE_32BIT a ' vero' nel proprio ambiente .        O uno vi permetterà di utilizzare i binari a 32 bit, ma per favore sii        consapevoli del fatto che questi scompariranno in una versione futura di Android SDK .        Prevedere il passaggio ad un sistema Linux a 64 -bit prima che ciò accada .

Ho cercato di risolvere il problema impostando export ANDROID_EMULATOR_FORCE_32BIT = true per gedit .profile file e per Gedit file .bashrc . Niente è cambiato .

Grazie per aver cercato di aiutare me !



Top 5 Respuesta

1shuofei @

Risolvo questo problema con il seguente :

export ANDROID_EMULATOR_FORCE_32BIT = true

Poi comincio l'emulatore dalla riga di comando . Funziona!

Spero che sia utile a voi .



2jakob @

Ho una grande soluzione . è possibile avviarlo con eclissi o NetBeans . prova :

In Eclipse, fare clic sulla cartella del progetto Android e quindi selezionare Esegui > Configurazioni Run ...

Nel pannello di sinistra della finestra di dialogo Esegui Configurazioni, selezionare la configurazione di esecuzione del progetto Android o creare una nuova configurazione .

Fare clic sulla scheda Destinazione .

Nel campo Emulator comando Opzioni aggiuntive, digitare :

-force-32bit

Eseguire il progetto Android utilizzando questa configurazione corsa .

in NetBeans voi : 1. wher si sceglie debuger scelto Personalizza ...

in Emulator options write -force-32bit click ok. and run application 3Ameen Maheen @

Ho fatto la seguente

vai alla configurazione di esecuzione > scheda target> scorrere fino all'ultimo > opzioni della riga di comando dell'emulatore supplementare> -force - 32bit

4patrick @

creare uno script di shell :

#!/bin/bash
#
#   set export ANDROID_EMULATOR_FORCE_32BIT=true

export ANDROID_EMULATOR_FORCE_32BIT=true
/opt/adt-bundle-linux-x86-20140702/eclipse/eclipse

cambiare il script eseguibile e lanciarlo di eclissi attiva " / opt / ADT - fascio - linux - x86-20140702 / eclipse / eclipse " è il percorso di eclissi