Ha ottenuto un errore durante la costruzione di un progetto di nuova area di lavoro

? Harikrishnan @ | Original: StackOverFlow

Sono nuovo di sviluppo Android . Ho cercato di creare un nuovo spazio di lavoro con target SDK come API 21 e compilati con API 19. Ho installato l'SDK di API19 e 20 e non il Android5 . Ho creato un nuovo spazio di lavoro e creato un nuovo progetto in cui ho finito con l'errore sotto durante la compilazione del progetto dopo averlo creato . Qualcuno mi può aiutare come sbarazzarsi di questo ?

Error details:



Top 5 Respuesta

1QArea @

Hai cambiato build target del progetto di Android 4.4.2 troppo ?

Qui i ragazzi hanno avuto lo stesso problema : http://stackoverflow.com/a/14843198/3864698



2Muhammad Ebad @

Una antera cosa che si può provare è quello di aprire il file project.properties del android - supporto - v7 - appcompat e cambiare il target di destinazione . E poi basta fare un progetto - > Pulire in modo che le modifiche abbiano effetto .

3Andy Dent @

Ho ottenuto un errore simile a qualcuno di nuovo per l'installazione di strumenti di Android e di aver erroneamente scelto il 4.4W e 4.4.2 nel Gestore Android SDK.

Ciò si traduce in avere entrambi API 20 e API 19 installato il che significa API 20 sembra essere più recente e sarà ripresa da default per i nuovi progetti .

Tuttavia, API 20 è Wearables Solo .

Potete vedere qui in Ha ottenuto un errore durante la costruzione di un progetto di nuova area di lavoro che 4.4W ha finito il percorso .

Sia il appcompat_v7 e obiettivi del progetto HelloAndy avevano questo problema percorso .

Ho modificato project.properties per entrambi e cambiato target = android - 20 a target = android - 19 poi ha fatto un aggiornamento su entrambi i progetti ( tasto destro del mouse l' appcompat_v7 e altro progetto ) . Che aggiornati i percorsi di compilazione per puntare alla corretta SDK di Android .

4pokerface @

Aggiornare il file project.properties di appcompat v7, che ha : target=android-19 a target=android-21

Aggiornare anche google play services library ( da update intendo aggiornarlo in SDK Manager e ri - import, ecc )

5Adgaonker Shashank @

Basta rimuovere la linea stile dovunque si trova errore quindi pulire il vostro progetto

e rendere il vostro progetto 5.0 settato