Adt non crea predefinito ciao mondo, ma linea di comando fa

? minttux @ | Original: StackOverFlow
---

Il mio ADT ha funzionato correttamente come stessi qualunque visto in esercitazione fino due giorni fa, quando ho creato un progetto come prima e anche i selezionato " creare un'attività in bianco" e mi aspetto lo rende un progetto predefinito ciao mondo per me e un Main.java anche un file di layout xml, ma non crea più questo progetto predefinito ciao mondo . ho installato e aggiornato maggior parte delle cose in SDK Manager. ho creato un altro spazio di lavoro e ho fatto tutto ciò che potevo, ma non crea progetto predefinito ciao mondo . ma quando creo progetto dalla riga di comando funziona correttamente e fare un progetto mondiale ciao . perché ADT non lo fa ? è la lista dei pacchetti installati sul mio responsabile SDK

Adt non crea predefinito ciao mondo, ma linea di comando fa  Adt non crea predefinito ciao mondo, ma linea di comando fa

e la sua struttura di progetto in ADT che è vuota quando creo un progetto con attività di vuoto :

Adt non crea predefinito ciao mondo, ma linea di comando fa

Ma funziona in riga di comando . io uso lo stesso direttore sdk da linea di comando :

~/Program/Andr/adt/sdk/tools $ ./android create project --target 24 --name MyFirstApp --path MyFirstApp --activity Main --package com.mrg.myfirstapp
Created project directory: MyFirstApp
....

E rende progetto Helloworld :

Adt non crea predefinito ciao mondo, ma linea di comando fa

Il mio sistema operativo è Linux Mint 15-16bit :

$ uname -a
Linux mrg-samsung 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

E ' la mia versione di Java :

$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

e la mia versione ADT :

Adt non crea predefinito ciao mondo, ma linea di comando fa

---

Top 5 Risposta

1TGMCians @

As one guy said

Ho avuto lo stesso problema, anche se ho scaricato l'SDK di Android e ha fatto una installazione pulita, ma ho appena risolto esso . Ho provato a fare clic su " Help" - > " Controlla aggiornamenti ", e poi ho avuto un messaggio pop - up dicendo tutto era al corrente, ma dopo ulteriori ricerche è apparso a me non era aggiornato . Quello che dovete fare è cliccare su " Help" - > " Installa nuovo software" e installare (questo aggiornarlo ) da questo url : https://dl-ssl.google.com/android/eclipse/

Vedi qui filo https://code.google.com/p/android/issues/detail?id=66647

2minttux @

Questo problema è stato a causa della nuova versione del SDK e ADT così aggiornare ADT si prega di aggiungere questo indirizzo : https://dl-ssl.google.com/android/eclipse/ ** Siate consapevoli che non funziona con l'indirizzo emozionante cominciare http in modo da andare per installare nuovo software in ADT e procedere come segue:  Adt non crea predefinito ciao mondo, ma linea di comando fa

Poi Selezionare questa e premere Avanti e Avanti e di licenza e premere Fine accettare di scaricare e installare :  Adt non crea predefinito ciao mondo, ma linea di comando fa

Ora, dopo il riavvio ADT se si crea un progetto che possa funzionare un altro problema che ho visto è stata l' AVD non funziona correttamente non è possibile aggiungere nuovo dispositivo per risolvere questo problema eseguire questo comando dal percorso SDK :

~/Program/android/adt/sdk/tools $ ./android avd

Dopo aggiungere il dispositivo va a ADT e aperto AVD da Eclipse e premere Refresh  Adt non crea predefinito ciao mondo, ma linea di comando fa

Dovrebbe funzionare ora

3Shimon Rothschild @

I passaggi per risolvere : 1. Eclipse selezionare? / Installare nuovo software 2. incollare questo link . https://dl-ssl.google.com/android/eclipse/ 3. Ho visto due argomenti " Developer Tools " ( 5 articoli ) e NDK Plugins ( 1 Prodotto ) 4. Installare ogni articolo uno per alla volta e riavviare Eclipse 5. Dopo aver installato il sopra, Ciao Mondo è stato creato automaticamente con il frammento di file aggiuntivo .

4dixhom @

Ho incontrato lo stesso problema e riparato .

Ho cambiato la versione del target SDK da API 21 ( Android L) ad un'altra versione . E 'appena risolto il problema .

5g_brahimaj @

Ho avuto lo stesso problema, ma non sarebbe risolvere perché avevo già gli ultimi aggiornamenti . Dopo ore di ricerche l'unico modo di fissare era per scaricare una nuova copia di Eclipse e creare un nuovo spazio di lavoro . Than seguire i passaggi che minttux ha specificato . Spero che aiuta per le versioni più recenti di Eclipse .