Android Studio Gradle problema l'aggiornamento alla versione 0.5.0 - Gradle Migrazione da 0,8-0,9 - Anche Android Studio aggiornamento a 0.8.1

? Cedric Simon @ | Original: StackOverFlow
---

Dopo stati di segnalazione di aggiornamento :

Failed to refresh Gradle project 'XXX'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Stesso tipo di problema dopo l'aggiornamento di Android alla versione Studio > = 0.8.0

---

Top 5 Risposta

1Cedric Simon @

Per risolvere il problema, aprire il file denominato build.gradle nella root del progetto, e cambiare versione Gradle lì a 0,9 . + .

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Per essere ripetuta per ogni progetto; (

Se quindi si ottiene un messaggio del tipo " Impossibile caricare la classe ' org.gradle.api.artifacts.result.ResolvedComponentResult " .

Vai a te project_folder/gradle/wrapper directory e modificare Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'. file di cambiare il distributionUrl per

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

Dopo l'aggiornamento alla versione 0.8.1 ( download completo e copiare la cartella SDK sopra ), doveva avere la nuova versione di Gradle installato da IDE ( utilizzando il "Fix it" collegamento di un paio di tempo : S ), e modifing la sezione " android " del file Gradle nella cartella di progetto 19,0-19,1, come di seguito :     buildscript {         repository {             mavenCentral ( )         }         dipendenze {             classpath ' com.android.tools.build:gradle:0.12.+ '         }     }     applicare plugin: ' Android '

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 19
    buildToolsVersion '19.1.0'

    defaultConfig {
        minSdkVersion 7
        targetSdkVersion 19
    }
}

dependencies {
    compile 'com.android.support:appcompat-v7:19.1.+'
    compile 'com.android.support:support-v4:19.1.0'
}
2Gabriele Mariotti @

Android Studio 0.5.0 richiede Gradle -plugin 0.9.0

Il Gradle -plugin 0.9.0 funziona con Gradle 1.10 o 1.11 Gradle

Modificare lo script build.gradle come suggerito da Cedric .

C'è una relazione tra Gradle -plugin e la versione Gradle . per esempio

com.android.tools.build:gradle:0.6.+   -> gradle 1.8
com.android.tools.build:gradle:0.7.+   -> gradle 1.9
com.android.tools.build:gradle:0.8.+   -> gradle 1.9/1.10
com.android.tools.build:gradle:0.9.+   -> gradle 1.10/1.11
com.android.tools.build:gradle:0.10.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.11.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.12.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.13.+  -> gradle 2.1
com.android.tools.build:gradle:0.14.+  -> gradle 2.1
com.android.tools.build:gradle:1.0.+   -> gradle 2.2.1

È possibile trovare la versione Gradle utilizzato nel progetto nel file gradle/wrapper/gradle-wrapper.properties

Inoltre vi è una relazione tra Gradle -plugin e la versione IDE . AGGIORNATO AL 2014/08/12 :

Android Studio 0.3.x  -> gradle-plugin 0.6
Android Studio 0.4.x  -> gradle-plugin 0.7
Android Studio 0.4.3+ -> gradle-plugin 0.8
Android Studio 0.5.x  -> gradle-plugin 0.9
Android Studio 0.5.8  -> gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9  -> gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x  -> gradle-plugin 0.11.+
Android Studio 0.8.x  -> gradle-plugin 0.12.+
Android Studio 0.8.11+  -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x  -> gradle-plugin 0.14.+
Android Studio 1.0.0  -> gradle-plugin 1.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

Per notizie aggiornate è possibile controllare questo link: http://tools.android.com/recent

Se si cambia la versione plugin, verificare la compatibilità, e quindi fare clic su progetto di sincronizzazione con il vostro files.It Gradle scaricherà una nuova versione del plugin se ne avete bisogno .

3pierre renoir @

hmm Sto ottenendo questo errore quando provo ad aggiungere questa dipendenza .

Errore : ( 22 ) è verificato un problema di valutazione del progetto ' : app' .

Impossibile trovare il metodo classpath ( ) per gli argomenti [ com.android.tools.build:gradle:0.9.+ ] sul progetto ' : app' .

Ok risolto . Questa linea dovrebbe essere parte del build.gradle "nella root del progetto ", come detto in precedenza, ma non mi hanno riconosciuto . Aggiornare gli strumenti di compilazione per 19.03 realmente inserito in automatico .

4lucidbrot @

Ho avuto lo stesso errore, ma già aveva

classpath 'com.android.tools.build:gradle:0.9.+'

set come questo, come Cedric Simon suggerito . Grazie al commento di mattblang, ho provato a cambiare a 0.9.0 e rinfrescato esso

per coloro che non conoscono, in cui il pulsante di aggiornamento è, guarda qui sotto :

Android Studio Gradle problema l'aggiornamento alla versione 0.5.0 - Gradle Migrazione da 0,8-0,9 - Anche Android Studio aggiornamento a 0.8.1

Poi ho provato quello che succede quando cambio di nuovo a 0,9 . + E rinfresco di nuovo ... e funziona ancora .

Quindi presumo, solo premendo il pulsante di aggiornamento sarebbe stato sufficiente .

5codercat @

Il più semplice progetto Android ha il seguente build.gradle :

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.0'
    }
}

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"
}

Ci sono 3 aree principali di questa build file Android :

http://tools.android.com/tech-docs/new-build-system/user-guide