Jar mancata corrispondenza ! Fissare le dipendenze utilizzando appcompat_v7 e Facebook sdk .

? KousiK @ | Original: StackOverFlow
---

Sto usando appcompat_v7 biblioteca e facebook sdk nel mio progetto e sia la biblioteca ho android -support- v4.jar.If I eliminare qualsiasi del vaso della biblioteca corrispondente non funziona e aventi sia vasi non è permesso .

Cosa dovrei fare? Gentilmente aiutarmi ...

---

Top 5 Risposta

1Raghunandan @

Il conflitto è dovuto a diverse versioni del vaso .

Assicuratevi di avere la libreria di supporto di aggiornamento da parte del direttore Android SDK

Copy android-support-v4.jar per librerie di entrambi i progetti . Il vaso può essere trovato @

android-sdk/extras/android/support/v4/andorid-support-v4.jar

Pulire e costruire il vostro progetto

2milapTank @

rimuovere android - sostegno - v4.jar da Facebook SDK e aggiungere android -support- v4.jar come vaso esterno immobili facebookSDK - > percorso java costruire - > biblioteche - > aggiungi vaso esterno ( ho avuto rimuovere questo problema come questo )

3user2678995 @

Provare a rimuovere la libreria di dipendenza sia appcompat_v7 e il vostro progetto . Per fare questo ha per costruire il percorso = > Percorso configure build. Quindi selezionare la libreria di dipendenza e cliccare su Rimuovi . Aggiungere la libreria di supporto per Android Tools = > aggiungere libreria di supporto . Fate questo per entrambi projects.Then siete pronti per partire

4Safdar Akrami @

La sua davvero semplice

Basta fare clic destro sul progetto e sul progetto di libreria > strumenti Android > Aggiungi sostegno Biblioteca .

Questo aggiornerà il libreria di supporto per il più recente che risolve il problema .

5Rahul Mandaliya @

Questa domanda è chiedere più volte, mentre tutti sono start- up di sviluppo Android in fase di apprendimento . Penso che ognuno di noi ha lo stesso ambiente di Android ma configurare in modo diverso secondo i progetti .

Ho avuto lo stesso problema durante la creazione di nuovi progetti e ogni volta ho trovato la soluzione in seguito . Ho aggiunto appcompat_v7 libreria nel progetto e rimuovo jar android-support-v4.jar dalla cartella lib del mio nuovo progetto e le palpebre ERROR non c'era più. Aggiungi appcompt_v7 progetto di biblioteca  Jar mancata corrispondenza ! Fissare le dipendenze utilizzando appcompat_v7 e Facebook sdk .

Rimuovere android - sostegno - v4.jar dalla cartella lib progetto  Jar mancata corrispondenza ! Fissare le dipendenze utilizzando appcompat_v7 e Facebook sdk .

Wow errore era andato  Jar mancata corrispondenza ! Fissare le dipendenze utilizzando appcompat_v7 e Facebook sdk .