Messaggio di errore : Questo SDK Android richiede Android Developer Toolkit versione 22.6.1 o superiore

? kuba @ | Original: StackOverFlow
---

Recentemente ho incontrato seguente errore :

Messaggio di errore : Questo SDK Android richiede Android Developer Toolkit versione 22.6.1 o superiore

La cosa più strana è che ho appena aggiornato qualche pacchetto da sdk via eclissi di lavoro . Non c'era alcuna informazione o avviso che dopo questo aggiornamento ADT attuale andrà in crash . Ho controllato gli ultimi aggiornamenti e non riesco a trovare un nuovo ADT anche nella pagina di google . Anche i nuovi adb contengono vecchio ADT .

Da http://developer.android.com/tools/sdk/tools-notes.html :

Dipendenze : Android SDK Platform -tools di revisione 18 o successivo . Se   stanno sviluppando in Eclipse con ADT, notare che questa versione di SDK   Tools è progettato per essere utilizzato con ADT 22.6.1 e versioni successive. Se non si dispone di   già, aggiornare il ADT Plugin per 22.6.1 .

L'unica soluzione è quella di scaricare nuova eclissi standalone e plugin esterno per esso ? Ha l'androide studio di affrontare gli stessi problemi ?

Ambiente : linux x64 .

---

Top 5 Risposta

1beworker @

Ho segnalato https://code.google.com/p/android/issues/detail?id=67325 ieri . La soluzione è usare Aiuto - > Installa nuova opzione software con protocollo https: // ( s è importante ) . Nessun download speciali o reinstallazioni è necessario, basta scegliere il sito di aggiornamento a destra .

2Robi Kumar Tomar @

Oggi io e uno dei miei amici affrontato lo stesso problema, così ho provato molte cose, come il riavvio eclissi, il controllo degli aggiornamenti, ecc, ma nessuno stava lavorando per me .

Poi ho trovato una soluzione da http://developer.android.com/sdk/installing/installing-adt.html e sta funzionando come un fascino per me e anche per il mio amico .

Seguire la procedura qui :

Start Eclipse, then select Help > Install New Software. Click Add, in the top-right corner.

Nella finestra di dialogo Aggiungi Repository che appare, digitare " ADT Plugin " per il Nome e il seguente URL per la posizione :

https://dl-ssl.google.com/android/eclipse/

Click OK.

In caso di problemi l'acquisizione del plugin, provare a utilizzare "http " nella posizione URL, invece di " https" ( https è preferito per motivi di sicurezza ) .

In the Available Software dialog, select the checkbox next to Developer Tools and click Next. In the next window, you'll see a list of the tools to be downloaded. Click Next. Read and accept the license agreements, then click Finish. If you get a security warning saying that the authenticity or validity of the software can't be established, click OK. When the installation completes, restart Eclipse. 3TGMCians @

Per risolvere questo problema, passi qui ho coperto, sicuramente vi aiuterà .

Please follow these steps:

Aiuto | Installare il nuovo software

Selezionare il sito di aggiornamento ADT ( ce ne sono due, uno con http : // e una con https : // Se uno non funziona, provare l'altro .

Selezionare la sezione strumenti di sviluppo e premere avanti .

Si dovrebbe vedere una finestra di dialogo che dice " questo software è già installato, un aggiornamento verrà eseguito invece " . Facendo clic su OK porterà a 22.6.1 installato.

Update 27/03/2014

http://developer.android.com/tools/sdk/eclipse-adt.html#notes

Potete vedere questa discussione : https://code.google.com/p/android/issues/detail?id=67325

4babelsistemas @

Il problema è che il sito di aggiornamento di default in Android ADT è

http://dl-ssl.google.com/android/eclipse/

ma questo sito non aggiorna correttamente

E la soluzione è aggiungere un nuovo sito di installazione con protocollo https

https://dl-ssl.google.com/android/eclipse/

Fare clic su in Aiuto-> Installa nuovo Software- > Aggiungi

E utilizzare questo sito per aggiornare ADT

Problema : https://code.google.com/p/android/issues/detail?id=67325