Errore : Questo SDK Android richiede Android Developer Toolkit versione 22.6.1 o superiore

? TheLittleNaruto @ | Original: StackOverFlow
---

Ho installato la versione ADT 22.6.1 già due giorni fa. Si stava lavorando bene . Improvvisamente, quando apro eclissare oggi, mi tiene mostrando seguente errore :

Questo SDK Android richiede Android Developer Toolkit versione 22.6.1 o superiore . La versione attuale è 22.2.1.v201309180102-833290 . Aggiornare ADT alla versione più recente .

Ecco screenshot di Android SDK Manager mia eclissi :  Errore : Questo SDK Android richiede Android Developer Toolkit versione 22.6.1 o superiore

Ho provato con i seguenti passaggi per risolvere il mio problema, come discusso in questo https://code.google.com/p/android/issues/detail?id=67325

Help | Install new software Select the ADT update site (there are two, one with http:// and one with https://. If one doesn't work, try the other. Select the developer tools section and press next. You should see a dialog that says This software is already installed, an update will be performed instead. Clicking OK will lead to 22.6.1 being installed.

Ma purtroppo non ha funzionato per me .

Ecco uno screenshot vi allego il che dimostra l'errore che sto ottenendo durante l'aggiornamento degli strumenti .

Errore : Questo SDK Android richiede Android Developer Toolkit versione 22.6.1 o superiore

Come faccio a sbarazzarsi di esso ?

---

Top 5 Risposta

1X-ELECTRON @

Basta eliminare la ADT esistente e installare la nuova versione di ADT.generally questi problemi si verifica      quando si aggiorna SDK utilizzando il collegamento sotto .

https://dl-ssl.google.com/android/eclipse/
2Lalit @

Ho risolto questo problema ieri .

Seguire la procedura : Aiuto - > Install New Software - > Aggiungi - > ( Dare un nome supponiamo NewUpdate ) - > aggiungere questo url : https://dl-ssl.google.com/eclipse/plugin/4.2 - > OK

Ora elencherà gli aggiornamenti disponibili, che dovrebbero idealmente essere 20.xx adt

Selezionare le voci di elenco Let it essere installato. Eclipse si riavvia e il suo fare .

Spero che questo sia utile per voi :)

3blue @

L' ADT Bundle su developer.android.com mi sembra come non aggiornati .

Ho risolto lo stesso problema http://eclipse.org/downloads/ ( Java EE è stata la mia scelta, ma si può scegliere il vostro gusto ) e http://developer.android.com/sdk/installing/installing-adt.html

4Rick Falck @

Attualmente ho Eclipse e ADT installato nella stessa directory

F:eclipse
    eclipse
    sdk

Ho scaricato e installato l'ultima ADT per

C:UsersRickAppDataLocalAndroidandroid-sdk

Poi ho copiato il contenuto del C:UsersRickAppDataLocalAndroidandroid-sdk nella cartella F:eclipsesdk, e lascio unire tutte le cartelle e sovrascrivere tutto .

Ora ho 22.6.1 e non dover riscaricare nuovamente tutta la roba piattaforma .

5Faruk Toptas @

Io uso OSX e affrontare il problema per 2 giorni . Ho risolto il problema seguendo le istruzioni riportate di seguito :

-Scaricare ADT Bundle da https://developer.android.com/sdk/index.html -help - > Install New Software -Scrivere Https://dl-ssl.google.com/android/eclipse/ quindi installare Strumenti per gli sviluppatori -restart Eclipse e sollevato l'errore sotto :

Android SDK content Loader has encountered a problem.parseSdkContent failed
java.lang.NullPointeException

-delete Cartella .android sotto profilo utente . eclipse Restart

È installato Nessun errore e 22.6.1 .