AVD non lancerà ( Tools SDK 22.6.2 )

? Robbe Van Winckel @ | Original: StackOverFlow
---

Ho scaricato il pacchetto ADT ( 22.6.2 ) . Quando si apre il Gestore Android SDK ho visto la versione di strumenti SDK era 22.3, l'aggiornamento disponibile per Strumenti SDK 22.6.2 . Ho provato a fare funzionare un emulatore prima e che ha funzionato perfettamente . Dopo che ho installato Tools SDK 22.6.2, insieme ad altre API . Quando ho cercato di aprire di nuovo un emulatore, non ha funzionato .

Posso creare, modificare e cancellare AVD di . Ma non si avvia . Dopo ho colpito launch, ho la schermata Starting Android Device, en la barra si riempie, ma non succede nulla . Ho provato a giocare con obiettivi diversi, differenti dispositivi, diversi RAM, ma senza alcun risultato .

Ho cercato di uccidere il server adb e riavviarlo. Non cambia nulla . Nessun dispositivo si presenta così quando cerco adb devices, anche se li ho fatti in Gestione AVD .

Mi sento come il problema ha a che fare con gli strumenti SDK hanno rev . 22.6.2 . Perché quando uso una nuova installazione ( Tools SDK essendo 22,3 ), tutto funziona .

Qualcuno sa una soluzione o sta tornando Strumenti SDK 22.3 l'unico?

EDIT : Questo è su OS X 10.6.8, non so se questo fosse degno di nota .

EDIT 2 : Le mie scuse per non rispondere per un lungo periodo di tempo . In ogni modo, il problema non è ancora risolto . Quando ho controllato per gli aggiornamenti, non erano disponibili . Quando ho provato a installare un nuovo software che mi ha detto che tutto era già installato . Ho usato https nonché http . I incontrollato " Contact tutti i siti di aggiornamento durante l'installazione di trovare il software necessario " . Non ho ancora idea di cosa potrebbe essere sbagliato .

---

Top 5 Risposta

1vincent @

http://developer.android.com/sdk/installing/installing-adt.html è la procedura da android.com . Ho avuto il problema di salvataggio . Questo funziona per me .

1.Download il http://dl.google.com/android/ADT-22.6.2.zip ( non scompattarlo ) . 2.Avviare Eclipse, quindi selezionare Guida > installare nuovo software . 3.Click Aggiungere, nell'angolo in alto a destra . 4.In la finestra di dialogo Aggiungi Repository, fare clic su Archivia . 5.Selezionare il file ADT-22.6.2.zip scaricato e fare clic su OK . 6.Immettere " ADT Plugin " per il nome e fare clic su OK . 7.In finestra Software disponibili, selezionare la casella di controllo accanto al Developer Tools e fare clic su Avanti . 8.In finestra successiva, verrà visualizzato un elenco degli strumenti da scaricare . Fare clic su Avanti . 9.Read e accettare gli accordi di licenza, quindi fare clic su Fine . Se si riceve un avviso di protezione dicendo che l'autenticità o la validità del software non è possibile stabilire, fare clic su OK . 10.Quando l' installazione viene completata, riavviare Eclipse .

2Lance Preston @

Vi consiglio di re- installare il plug -in ADT 22.6.2 . Per reinstallare, in primo luogo individuare la cartella eclipse ( il luogo che si estrae eclissi ) . Nella radice della cartella eclissi, si dispone di una cartella denominata "plugins" . Eliminare tutti i contenuti della cartella. Ora, indirizzare il browser per andare qui e scaricare l' ADT 22.6.2 archivio zip : http://dl.google.com/android/ADT-22.6.2.zip

Non scompattare l'archivio . Launch eclissi . Vai alla Guida - > Installa il nuovo software - > Clicca su ' Aggiungi ' - > dargli un nome come " ADT Plugin ' - > Clicca su archivio e sfogliare per lacation dove appena scaricato l'archivio zip ADT e selezionarlo - > Hit OK - > Accettare i contratti di licenza e procedere con l'installazione .

Regards!

3jomafer @

Ho avuto lo stesso problema di oggi . Ho cercato di riavviare Eclipse, controllare gli aggiornamenti e erano disponibili aggiornamenti .

La soluzione per me era di aprire Eclipse / Aiuto / installare nuovo software, aggiungere questo URL in " Lavorare con " sezione :  http://dl-ssl.google.com/android/eclipse/

e installare gli strumenti per sviluppatori .

4Kiet @

Da questa discussione, http://code.google.com/a/eclipselabs.org/p/jvmmonitor/issues/detail?id=82

" Risposta rapida : deselezionare" Contatta tutti i siti di aggiornamento durante l'installazione di trovare il software necessario " "

La casella di controllo è all'interno Aiuto- > Installa nuovo Software- > Installa

Funziona per me .

5SPRBRN @

Ho avuto questo problema pure, e fissato come segue :

I removed all ADT and Android plugins. On OSX this is done via Eclipe (menu) > About Eclipse. On Windows via Help > About Eclipse and then the button Installation details. Then I reinstalled the ADT plugin via Help > Install new software Check for updates. Uncheck Hide items that are already installed, because then the update that you need might be hidden. Check only the 22.6.2 update and run it. Restart Eclipse and see if the problem is fixed. Then install all updates as needed.

Quello fissato per me .