Risolvere problema di incompatibilità Gradle durante l'importazione di progetto di esempio Android

? Sebastien @ | Original: StackOverFlow
---

Android Studio ( 0.5.3 ) mi sta facendo impazzire .

Non ho mai avuto problemi seri con Eclipse e ADT . Android Studio è un'altra storia : non sono stato in grado di ottenere un unico progetto per costruire correttamente con esso .

Quindi, sto cercando di importare un progetto di esempio Android (che suppongo ha impostazioni Gradle corretti e devono pronto per essere importato ) :

C:pathToMyAndroidSDKsdksamplesandroid-19contentStorageProvider

Il primo errore che ottengo è il seguente :

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of Gradle. Please use version 1.10.
Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.)
Fix Gradle wrapper and re-import project Gradle settings

OK, così ho scaricato Gradle 1.10, e modificare le impostazioni Gradle progetto, in modo che utilizzi questa distribuzione locale Gradle invece del involucro Gradle di default ( che sembra essere inclusi nel progetto di esempio ) .

Ottengo un errore di diverso questa volta :

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Non so Gradle sufficiente per migrare la configurazione me stesso, e non ho davvero voglia di .

Come posso usare semplicemente l'involucro Gradle senza gettting convocato utilizzare Gradle 1.10 ( che non è compatibile con il progetto ) ? Qualsiasi altra soluzione è inoltre benvenuto .

Nota : Ho provato con altri progetti di esempio nella cartella android - 19, solo per ottenere gli stessi errori .

EDIT:

Ho avuto più fortuna cercando di costruire sotto Linux con la riga di comando ( gradlew build ) .

La build è riuscito, indipendentemente da ciò che ho impostato in build.gradle :

classpath 'com.android.tools.build:gradle:0.9.+'

or

classpath 'com.android.tools.build:gradle:0.8.+' #(the original configuration of the sample project)

Quindi il mio problema sembra essere causato da errori di Android Studio .

---

Top 5 Risposta

1Gabriele Mariotti @

Senza saperlo Gradle, è abbastanza difficile da risolvere il problema .

Contemporaneamente Android Studio è una versione alpha, in modo che possa cambiare rapidamente, e ogni versione può introdurre modifiche incompatibili

Ecco il primo documento da leggere su un progetto con Android Studio :  https://developer.android.com/sdk/installing/studio-build.html

Si utilizza AS 0.5.3 in modo da usare Gradle 1.10 / 1.11 e il plugin 0.9.x Gradle

Ciò significa che nello script build.gradle devi usare :

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Può essere nel file avete 0.8.3 .

Inoltre è necessario utilizzare Gradle 1.10 / 1.11 . Si dovrebbe avere una cartella * project_folder / Gradle / involucro * dove c'è un file gradle-wrapper.properties .

Qui dovete cambiare la chiave distributionUrl di utilizzare una di queste versioni :

distributionUrl = http : //services.gradle.org/distributions/gradle-1.10-all.zip

Android Studio - Gradle - Gradle plugin di avere qualche relazione :

http://stackoverflow.com/questions/22252956/android-studio-gradle-issue-upgrading-to-version-0-5-0-gradle-migrating-from-0/22256954#22256954

Può essere lo script Gradle può avere altri problemi dopo queste modifiche .