Progetto nuova applicazione Android non può creare Blank Activity

? Nikolius @ | Original: StackOverFlow
---

Sono ancora in fase di sviluppo nuovi Android e appena deciso di imparare . tuttavia ho incontrato qualche problema che mi impazzire questo paio d'ore .. Voglio solo creare un nuovo progetto con questa impostazione

Progetto nuova applicazione Android non può creare Blank Activity

Il problema è che non riesco a creare nuova attività vuota con esso, si dice che richiede una versione API build target di almeno 14, e la versione corrente è di 8

Progetto nuova applicazione Android non può creare Blank Activity

Voglio solo provare costruire un app che supportano da Android 2.2 ( API 8 ) in poi .. è che proprio non è possibile in questo momento per creare un Android 2.2 le applicazioni compatibili con modello di attività vuoto ? Quindi, al fine di utilizzare modello di attività vuoto devo utilizzare Android 4.0 ( API 14 ) ? è corretto?

---

Top 5 Risposta

1Shivansh Saxena @

Seguite questo link Penso che sia il posto migliore per imparare android da quella di base   https://developer.android.com/training/basics/firstapp/index.html?hl=it

2ojonugwa ochalifu @

Modificare il minimo SDK necessario per 9 e l'obiettivo SDK a 18

3user3439968 @

E ' nuova funzione di ADT 22.6.2

Anche in " None " tema ADT ( 22.6.2 ) creare "Layout Fragment "

C'è quattro modi :

Provate a cambiare "Target " e "Compila " per API 14 o superiore . Ma è necessario rimuovere tutte le voci di " Fragment Layouts "

Deselezionare "Crea attività " checkbox, e creare manualmente l'attività . Buono howto :  http://stackoverflow.com/questions/2337874/best-way-to-add-activity-to-an-android-project-in-eclipse

Downgrade a 22.3.0 per esempio

Prova a modificare i modelli . Nel link qui sotto trovate howto .

Io uso terza via per le mie applicazioni con API inferiori 14. In diverse directory ho installato 22.3.0 e 22.6.2

C'è in 22.6.2 è alcuni altri bug con i file vuoti e problemi con AVD . Nuova versione di ADT davvero buggy ...

Guardate anche questo link :

http://stackoverflow.com/questions/22289164/adt-blank-activity-created-with-fragment-activity

http://stackoverflow.com/questions/22278479/eclipse-doesnt-generate-mainactivity-java-activity-main-xml

e cercare, sì )

http://stackoverflow.com/search?q=adt+22.6

Aggiunti nuovi modi .

Come lo uso ora :

You can create project in 22.3.0 or lower. Then open it in 22.6 or greater. You can create project in 22.3.0 or lower and leave it blank. Then in 22.6 or greater you can use this blank project as template. Just copy this template-project and past it with new name as you new-project in Eclipse workspase.

Enjoy! )

4user3459475 @

che sta per essere edificio difficile per tale versione, è possibile lasciare minima Sdk a yoru desiderato . Ancora si deve aumentare massimo, anche se il minimo è niente di meno che il 15, il ADK sta costruendo una cartella extra ( novità ) In realtà la nuova versione di ADT è fastidioso, sto solo iniziando e ora vedrete che hanno forzata l' uso di frammenti .

5Harison Silva @

Ho capito che possiamo usare Empty attività invece di Blank Activity . Ora in vuoto è stato creato un frammento, layout e R.java viene aggiornato .