Questo modello richiede una versione API build target di almeno 14, e la versione corrente è di 8

? Vibhor Bhardwaj @ | Original: StackOverFlow
---

Ho lavorato con Android Developer Tool da molto tempo senza issue.Recently ho aggiornato il mio ADT e ora sono in grado di creare una semplice attività da ( Nuovo- > Altri- > Attività Android ) .Si sta fornendo unica opzione per creare bar Azione Activity .

Così Come creare un'attività semplice con il layout  Questo modello richiede una versione API build target di almeno 14, e la versione corrente è di 8

La mia versione ADT è 22.6

---

Top 5 Risposta

1Mdlc @

Perché succede questo Il modello che si sta tentando di aggiungere utilizza funzionalità (come la ActionBar ), che richiede un livello di API superiore a 14, nella prima fase della procedura guidata, è stato selezionato 9. E dal 9 < 14 si ottiene questo errore .

What can I do

Chose an higher minimum API level (at least 14 for this template). Go back to the first step and change the minimum api level. Chose a different template that is more compatible, by going back one step and select the most basic template.

Quale dovrei scegliere Se si pensa che non importa a utilizzare un livello di API superiore 14 ( in modo che il dispositivo non funzionerà su dispositivi cream sandwich pre - ghiaccio), si dovrebbe assolutamente prendere la prima opzione . Se non ti dispiace utilizzando un modello più semplice -UI per cominciare, e avete bisogno realmente la vostra applicazione per lavorare su pre - ice cream sandwich dispositivi . Si dovrebbe scegliere la seconda opzione .

Cosa devo fare se voglio entrambi Si potrebbe utilizzare una libreria di supporto, in questo modo si può godere di livello API 14+ funzioni su API pre 14 dispositivi . Alcuni ritengono più difficile da configurare & amp ; utilizzare comunque. https://developer.android.com/tools/support-library/setup.html ci sono anche campioni disponibili .

EDIT : In fase di seguito, è possibile selezionare il tipo di modello :, notare il segno di spunta " creare attività", basta deselezionare esso .  Questo modello richiede una versione API build target di almeno 14, e la versione corrente è di 8

2hunt @

Quando si crea un progetto, allora è necessario impostare le opzioni : min SDK, bersaglio SDK e compilare con . È possibile impostare min SDK a 10, indirizzare SDK a 10, ma "Compila con " impostata su API 14 .

3AWT @

Un trucco per questa irritazione potrebbe essere quella di impostare il livello di API a 14, creare la nuova attività, e quindi modificare il livello di API di nuovo a quello che vuoi che sia . Questo sembra essere un problema con questa versione di ADT e la nuova procedura guidata di creazione di attività .

Questo consente di lavorare prima, ma di recente ho aggiornato ADT e ora sto vedendo questioni su progetti che non ho cambiato .

Ho fatto questo per creare nuove attività e non ho visto ancora alcun problema .

4user3380823 @

Che fissa per me era in Eclipse andare al Progetto > Proprietà > Android poi controllare il più alto livello di API in Project scatola Corporatura Target ( API 19 per me )