Eclipse ( Android Bundle ) Crashing

? curious_coder @ | Original: StackOverFlow
---

Recentemente ho aggiornato a Ubuntu 14.04 . Da allora Eclipse è stato crollando . Il messaggio è

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x734be86d, pid=7930, tid=3076015872
#
# JRE version: Java(TM) SE Runtime Environment (8.0_05-b13) (build 1.8.0_05-b13)
# Java VM: Java HotSpot(TM) Client VM (25.5-b02 mixed mode linux-x86 )
# Problematic frame:
# C  [libsoup-2.4.so.1+0x5486d]  soup_session_feature_detach+0x1d
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/funcoding/Android Development/adt-bundle-linux-x86-20131030/eclipse/hs_err_pid7930.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

Ho anche provato ad aggiungere -Dorg.eclipse.swt.browser.DefaultType=mozilla" per eclipse.ini

Aggiornamento: Ho provato molte cose, ma continua a schiantarsi in modo imprevisto . Finalmente ho deciso di restare con Android Studio (Running modo migliore di ora ) .

---

Top 5 Risposta

1yqlong @

È possibile reinstallare eclissi .

Io avevo questo problema dopo l'aggiornamento a 14.04 . Ho scaricato l'ultima JRE, non ha funzionato . Poi ho avuto l'ultima eclisse e ora funziona .

2Ian @

Questa è solo una soluzione temporanea, e sono sicuro che non sarà selezionato come una risposta, ma sto mettendo questo qui in modo che chiunque abbia questo problema possa almeno continuare a utilizzare eclissi fino a trovare una soluzione migliore .

I suggerimenti sembrano essere la causa del problema così li ho disabilitato . Sono in grado di continuare la programmazione e non ho avuto crash su di me di nuovo ( ancora ) .

Per disabilitare i suggerimenti vanno a Windows> Preferenze> Java > Editor > Hovers e deselezionare tutto il testo hover preferenze modificatori chiave .

Spero che questo aiuta .

edit:

Si blocca anche quando eclissi tenta al contenuto assistere gli utenti . Per disabilitare questo andare a Windows > Preferenze > Java > Editor > Content Assist . Scorrere verso il basso per l'attivazione automatica e disabilitare l'attivazione automatica

3vitriolix @

Sono in esecuzione Ubuntu 14.04 e stavo questo con il fascio ADT Android di eclissi . Installazione eclissi tramite Ubuntu Software Center e quindi l'installazione di ADT tramite le istruzioni legate seguito ha lavorato per me .

http://developer.android.com/sdk/installing/installing-adt.html

4Logko @

Questo bug è stato segnalato qui : https://bugs.eclipse.org/bugs/show_bug.cgi?id=404776

Correzione descritta nei commenti che funziona anche per me è quello di aggiungere questa riga alla fine del file eclipse.ini

-Dorg.eclipse.swt.browser.DefaultType = Mozilla

5xcottos @

questo non è probabilmente la soluzione più intelligente, ma sicuramente risolto i miei problemi :

dopo aver giocato con i parametri eclipse.ini Ho chiesto ad un mio amico mi desse la sua eclipse.ini basata su Kepler e ho scoperto che alcuni pacchetti invocati in avvio sono più recenti di quelli che vengono con il pacchetto ADT .

So I:

1 ) installato una nuova copia di Kepler 2 ) usato il sito di aggiornamento di Android per aggiungere il quadro Android 3 ) dopo il riavvio che mi ha chiesto di aggiornare l' SDK Android

Finora non ho avuto alcun incidente ( completamento automatico, ecc ) in modo che sembra che risolto il problema ...

hope that helps

Luca