Google - play- services_lib Impossibile risolvere target ' android- 9

? Randolphg @ | Original: StackOverFlow
---

Quando avvio il mio ADT Android la maggior parte se non tutti i miei progetti hanno un punto esclamativo rosso accanto a loro . E quando cerco di costruire ed eseguire ottengo un errore :

"google -play - services_lib ] Impossibile risolvere target ' android - 9 ' "

Non sono sicuro che cosa questo significa come sono al passo con i miei aggiornamenti con il mio manager Android SDK .

Ho provato a riavviare Eclipse. Ho provato a scaricare un altro SDK Android e che parte da lì, ma ancora lo stesso errore .

Si prega di aiutarmi a guidare nella giusta direzione .

---

Top 5 Risposta

1Rod_Algonquin @

la sua versione sdk Mnimum in ur manifesta il suo dovrebbe essere più che la versione 9

2user3640330 @

In realtà il download l'ultimo pacchetto ADT per Eclipse dà lo stesso errore quando si cerca di importare il google_play_services_lib ( 17 ) . http://developer.android.com/sdk/index.html#download

Aprire il SDK Manager, fare clic obsolete ( così API 9 si presenta ), e prendere API 9. Questo è davvero qualcosa che sembra una semplice svista e dovrebbe essere risolto . Spero che questo aiuta gli altri .

3Andrew @

Ho avuto questo problema compare dopo l'installazione degli aggiornamenti più recenti utilizzando il ADT .

In eclissi Ho il mio progetto e un progetto per la google - play- services_lib .

Ho scoperto che se si modifica la versione minima sdk ( come detto in precedenza ) a più di 9 non è sufficiente . Ho anche dovuto cambiare il "Progetto obiettivo di costruire " ( Proprietà / Android / ) in base alla versione che avevo messo nel manifesto .

4jsanmarb @

Ho sistemato le proprietà del progetto impostazione l'obiettivo di costruzione del progetto :

Google - play- services_lib Impossibile risolvere target ' android- 9

Che lavora per me .

5Shashidhar @

Cambio android: minSdkVersion = " 9 " per più di 9 nel file di AndroidManifest.xml cioè, android : minSdkVersion = " 10 " In questo modo ho risolto il mio problema Spero che questo aiuti !!