Android studio - Costruire errore di script, metodo DSL supportato Gradle trovato : ' android ( ) ' !

? helloworld @ | Original: StackOverFlow
---

Sto ottenendo il seguente errore in Android Studio 0.4.2 quando sto cercando di sincronizzazione progetto con Gradle .

Gradle 'GooglePlayServicesTest' project refresh failed:
       Build script error, unsupported Gradle DSL method found: 'android()'!

My progetti di file Gradle è la seguente : -

buildscript {
repositories {
    mavenCentral()
}
dependencies {
    classpath 'com.android.tools.build:gradle:0.7.+'
}
}

allprojects {
repositories {
    mavenCentral()
}
}


android{

compileSdkVersion 19
buildToolsVersion "19.0.1"

defaultConfig {
    minSdkVersion 10
    targetSdkVersion 19
    versionCode 1
    versionName "1.0"
}

sourceSets{
    main{
        manifest.srcFile 'GooglePlayServicesTest/src/main/AndroidManifest.xml'
    }
}
}

file di Gradle di modulo: -

apply plugin: 'android'

android {
compileSdkVersion 19
buildToolsVersion "19.0.1"

defaultConfig {
    minSdkVersion 10
    targetSdkVersion 19
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        runProguard false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
    }
  }
}
dependencies {
compile 'com.android.support:appcompat-v7:+'
}

anche io ho rimosso il miniSDKVersion e targetSDKVersion da AndroidManifest.xml

qualcuno può aiutarmi a risolvere questo errore .

---

Top 5 Risposta

1fookwood @

android Metodo file di Gradle progetto non è needed.Try rimuoverlo .

2hamid @

Aggiungere top del progetto build.gradle file:

apply plugin: 'com.android.application'