Genymotion su Windows 7 è in grado di connettersi al dispositivo virtuale

? more whirlpools @ | Original: StackOverFlow
---

Sono stato con Genymotion per circa un mese, e ha funzionato bene . Tuttavia, durante la scorsa settimana ho ricevuto questo errore, indipendentemente dalle mie impostazioni:

Genymotion su Windows 7 è in grado di connettersi al dispositivo virtuale

"Impossibile connettersi al dispositivo virtuale! Genymotion ora fermare . Controllare la configurazione di rete VirtualBox . "

e un link per maggiori informazioni :  https://cloud.genymotion.com/page/faq/#collapse-nostart

Ho seguito i passi lì, e l'emulatore ancora non funziona .

Sono in esecuzione Google Nexus 4 - 4.4.2 - API 19 - 768x1280 e hanno provato con più emulatori di diverse API e tipologie . Sono in corso anche un sistema operativo a 64 bit di Windows 7 .

Ho disinstallato e reinstallato sia Genymotion e VirtualBox, e ho ancora ottenere lo stesso errore . Dalla preview emulatore in VirtualBox, l'emulatore sembra funzionare normalmente, ma Genymotion è in grado di collegarsi a questo dispositivo . Esecuzione del emulatore da VirtualBox sembra funzionare bene ; purtroppo non è possibile connettersi a Eclipse da lì .

Come posso risolvere questo problema? Il fatto è che l'emulatore ha lavorato prima, e non funziona ora .

---

Top 5 Risposta

1more whirlpools @

EDIT : Si scopre che Genymotion ha problemi mentre il suo utente sta eseguendo una VPN, che spiega i problemi di connessione .

Ho fissato io stesso .

Il problema per lo più ha coinvolto la mia connessione a Internet .

Il server DHCP che Genymotion stava usando stava cercando di contattare l' indirizzo IP non utilizzato 0.0.0.100, che ha portato da nessuna parte .

Pertanto, ha portato il VirtualBox e Genymotion di scegliere le impostazioni errate per il server DHCP e l' indirizzo IPv4 . Quindi la mia soluzione era quella di disabilitare tutte le connessioni a Internet prima di iniziare Genymotion, ed è riuscito a correre senza problemi .

2msoliman @

Una buona risposta descrittiva per risolvere questo problema è http://stackoverflow.com/a/20018833/1334561 in un altro post . Inoltre, la soluzione potrebbe essere trovata in https://www.genymotion.com/#!/support?chapter=collapse-nostart#faq nella sezione denominata " Quando inizio un dispositivo virtuale, perché la finestra resta nero ? "

3user1679544 @

Ho affrontato questo problema e mi soloved come questo :

1 ) Vai a VirtualBox > File > Preferenze > scheda Nework

2 ) Selezionare VirtualBox - Host Only - Ethernet Adapter in Reti solo Host - : e quindi eliminarlo .

3 ) Riavviare il dispositivo virtuale