Android Studio Gradle BuildTools Revisione

? Gabriel Matusevich @ | Original: StackOverFlow
---

Ho un progetto Android in Android Studio 0.5.9 e Gradle sta gettando questo errore :

Error:The SDK Build Tools revision (17.0.0) is too low. Minimum required is 19.0.0

Ho già installato SDK creare strumenti di revisione 19 dal Gestore SDK e qui è la mia build.gradle

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.10.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.0"

    defaultConfig {
        minSdkVersion 9
        targetSdkVersion 17
    }

    sourceSets {
        main {
            manifest.srcFile 'Manantiales/src/main/AndroidManifest.xml'
        }
    }
}

Come faccio a dire Gradle utilizzare gli strumenti di costruzione 19 se è già installato ?

EDIT : ho segnato una risposta diversa, come la risposta migliore, perché era quello che ha lavorato per la maggior parte delle persone

---

Top 5 Risposta

1Gabriel Matusevich @

Ho trovato il problema, build.gradle era sulla cartella sbagliata

2Azurai @

Ho da poco aggiornato il mio studio per Android 0.6.0, ed è stato avermi dato lo stesso problema . Ma la mia generazione era 19.0.3, invece di 19.1.0 . Ho cambiato il buildToolsVersion " 19.0.3 " per - > " 19.1.0 ", che ha costretto il Gradle per scaricare gli aggiornamenti . Ho riavviato il mio Studio Android, e l'errore è andato via . Non so esattamente come spiegarlo, ma credo che lo costringe a scaricare la patch dal sito Maven, e fa la sua giustizia, dietro le quinte . E proprio come ha detto Gabriel Matusevich, il build.gradle si trova ProjectFolder - > AppFolder - > build.gradle

Eccezione : I Havn't completato testato questo fuori, ma ho notato la Gradle è stato scaricato dal sito, ho havn't aggiungere o eliminare il codice, o correva l'applicazione ancora . Quindi, per essere sicuri, ricordare il numero buildToolsVersion che aveva prima !

3Jorge Vieira @

Aprire SDK Gestione Android e assicurarsi di avere Costruire Tools 19.1 scaricati. Doppio controllo .

Poi trovare costruire / app.gradle e cambiare il numero di buildToolsVersion '19 .1 ' :

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion '19.1'
    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19

    }
4Xexiz @

Ho avuto lo stesso problema questa mattina dopo l'aggiornamento a .6.0 . È necessario cambiare voi versione Gradle in /projectName/build.gradle

classpath 'com.android.tools.build:gradle:0.11.+'

Aprire il gestore di SDK e scaricare la nuova versione degli strumenti di compilazione 19.1 quindi modificare la riga seguente in /projectName/moduleName/build.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

Poi la sincronizzazione dei file Gradle e si dovrebbe essere pronti per partire !

5RoQ @

Ciao per me dopo scaricare l'ultima versione degli strumenti di Android SDK, cambio la versione Android F4 ( Impostazioni modulo )

https://www.dropbox.com/s/9ypuepxfwlcp4e5/Captura%20de%20pantalla%202014-06-10%2000.45.38.png