Android Studio dopo l'aggiornamento a costruire strumenti 19.1.0

? Ilya_Gazman @ | Original: StackOverFlow
---

Appena aggiornato la mia versione di Android strumenti di compilazione a 19.1.0, e questo è quello che sto ottenendo :

Metodo non supportato : Dependencies.getJars ( ) .             La versione di Gradle si connette a non supporta questo metodo .             Per risolvere il problema è possibile cambiare / aggiornare la versione di destinazione di Gradle si connette a .             In alternativa, è possibile ignorare questa eccezione e leggere altre informazioni dal modello .: Metodo non supportato :   Dependencies.getJars ( ) .

Ho cercato tutte le mie librerie e dipendenze e tutto è impostato a 19.1.0

Che cosa mi manca ?

---

Top 5 Risposta

1Berdon @

La versione 0.11 del plugin Android Gradle è stato appena pubblicato ( 6/6/14 ) . Modificare le impostazioni build.gradle a " 0,10 . +" .

classpath 'com.android.tools.build:gradle:0.10.+'

Nota : Questo dovrebbe essere considerato una soluzione temporanea fino a quando è possibile aggiornare Android Studio e il vostro Android SDK ( in particolare gli strumenti di compilazione ) .

2Prakash @

Aggiornato Android Studio che ha risolto il problema .

3Yuki Yoshida @

questo errore si verifica in IntelliJ IDEA, troppo . e cerco qualche versione di IntelliJ IDE

costruire 19.1.0 strumento e plug Gradle 0,11

Android Studio 0.8.1 : build success IntelliJ IDEA 13.1 : this error still occurs at IU-135.760 IntelliJ IDEA 13.1 EAP : this error still occurs at IU-135.1019 IntelliJ IDEA 14 EAP : build success at IU-138.777

Non riesco a trovare questa correzione in 14 nota di rilascio di PAA, ma sembra essere fissato a 14 EAP .