Errore in Eclipse con appcompat_v7

? jkally @ | Original: StackOverFlow
---

Essendo nuovo Android developent ho seguito il più semplice di tutorial, costruito un nuovo progetto Android, accettando tutti default ( costruito per KitKat ) . Per il mio sgomento ho un progetto previsto un - appcompat_v7, insieme con gli errori :

Il contenitore riferimenti ' Android Dipendenze ' non libreria esistente ' C : ? Gli utenti ... workspaceappcompat_v7 inappcompat_v7.jar '

e due volte la seguente

Il progetto non può essere costruita finché non si determini errori di percorso di costruzione

C'è un modo rapido per risolvere questi? È questo un segno di quanto sia difficile, e spiati con spiacevoli sorprese apprendimento Android sta per essere ?

( Spero che non sarà simile ad imparare IOS 6 anni fa ... )

---

Top 5 Risposta

1ZygoteInit @

Il trucco è, è necessario pulire & amp ; costruire il progetto appcompat_v7 . Vai a Project - > selezionare Clean - > selezionare il progetto . Se il progetto non è costruita automaticamente, fare clic destro sul progetto nel pacchetto esplorare e selezionare Build Project . Ora il file .jar saranno generati nella cartella bin del progetto . Dopo di che, clean & amp ; costruire tutti i progetti che fanno riferimento a appcompat_v7 .

Note also that:

1. È necessario che le ultime versioni di strumenti SDK / Costruire Strumenti / Tools Platform . Se si tenta di questo e non funziona, poi andare al Gestore Android SDK e assicuratevi di avere le ultime versioni degli strumenti necessari .

2. Nel caso in cui il progetto richiede solo livello di API 14 ( Ice Cream Sandwich ) & amp ; sopra, selezionare il livello di API 14 per " minimo richiesto SDK " nel wizard di progetto quando si crea un nuovo progetto . Ora non sarà necessaria la libreria appcompat_v7 per questo progetto, e l'applicazione utilizzerà la classe ActionBar nativa che è presente in AOSP costruisce da ICS in poi .

2prabhakaran @

Hai bisogno di aggiornare il vostro gestore di SDK

clicca ur Icon Manager SDK nel ecilipse quindi aggiornare androide sostegno Repository negli extra

then

vai a File- > importazione > progetto esistente

circa Bundle- > sdk- > extra > Android- > SOSTEGNO- > v7 di lavoro

dopo l'importazione v7 per area di lavoro andare nella cartella lib scegliere sia vaso e fare clic destro e scegliere costruire nell'area di lavoro poi di nuovo a destra clicca progetto v7 andare a java percorso di generazione scegliere la casella di controllo e fare clic su Applica e OK ..

se u hanno aggiornato sdk quindi seguire questa procedura

step 1:

Fare clic destro ur progetto poi andare

proprietà- > scegliere java percorso di generazione

step 2:

fare clic su Aggiungi vaso esterno

Step 3:

Individuare ur pacchetto ADT andare a ur lavoro scegliere la cartella

android -support - v7 - appcompat - > lib - > appcompat_v7.jar

3CyberSpy_zero @

Ho avuto lo stesso problema e ho provato tutti mentionded sopra consigli e molto di più da, ma nessuno mi ha aiutato a risolvere il mio problema . La mia soluzione è stata la creazione di un Progect con minimo richiesto SDK API 14 : Android 4.0 ( IceCreamSandwich ) . Facendo in questo modo Eclipse non creerà appcompat_v7 progetto .

Inoltre ho trovato un altro, meglio, la soluzione :

Go to Android SDK Manager and install Android 5.0.1 (API 21) or newer. If you don't use the emulator you can install only SDK Platform and Google APIs; Go to appcompat_v7 -> Properties -> Android and check Android 5.0.1 in the Project Build Target; Then go to Java Build Path -> Order and Export and check Android 5.0.1; Do the same procedure for your project. 4BK Manly @

Appcompat_7 errore risolto !

Ciao, im un principiante assoluto, ho risolto il mio problema andare a Update Manager SDK / installo tutto il nuovo SDK di Android costruire strumenti ( come non sono sicuro che è che dovrei aggiornare / installare in modo che io aggiornare / installare tutti gli strumenti di compilazione . Dopo aggiornato / installato tutti i nuovi strumenti di compilazione chiusi eclissi e rilanciare l'eclissi di nuovo . se si vede ancora qualche errore ? Vai all'inizio bar click Progetto e scegliete PULITO . ed eseguire nuovamente l'applicazione e credo che funzionerà bene ..

5Don 3000 @

La risposta accettata lavorato per me, ma solo dopo che avevo installato l' ultima Java JDK ( che era una soluzione al problema dettagliato http://stackoverflow.com/questions/26474298/android-parsing-data-for-android-21 -failed )