Android SDK - Errore aapt : libstdc ++ so.6 Impossibile aprire il file oggetto condiviso .

? Dremor @ | Original: StackOverFlow
---

Stavo creando un nuovo progetto dal nulla, a scopo di test, lasciando tutti i parametri di default ( non ho fatto alcun cambiamento di codice ), in una nuova installazione ADT ( Ubuntu Gnome 14.04 LTS, x86_64 CPU), ma io ho il seguente errore nella console Eclipse :

[2014-06-11 09:03:10 - Kronos] /home/erwan/Applications/ADT/adt-bundle-linux-x86_64-20140321/sdk/build-tools/19.1.0/aapt: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Ecco quello che ho già provato :

- > Ho cercato di ( ri) installare ia32- libs, libstdc ++ e libstdc ++ 6 tramite repository software di Ubuntu : Nessun cambiamento

- > Controllato per l'aggiornamento ( per Eclipse e l' SDK ) : Nessun cambiamento

- > Reinstallare tutti i tool di sviluppo di Android : Nessun cambiamento

- > Reinstallare ADB : Nessun cambiamento

---

Top 5 Risposta

1Jayesh @

Si può provare qualcosa di simile

sudo apt-get install lib32stdc++6 lib32z1 lib32z1-dev
2weiyin @

Sul mio 64-bit di Ubuntu 14.04 desktop, questo era tutto il necessario :

sudo apt-get install lib32stdc++6
3user2773066 @

Anch'io ho un 64-bit di Ubuntu 14.04 del desktop, e la risposta corretta per l'installazione che è davvero :

sudo apt-get install lib32stdc++6