quando sto prendendo nuovo progetto Android appcompt sta mostrando un errore

? Rohit Bandil @ | Original: StackOverFlow
---

prima di questo errore il mio tutte le applicazioni stanno andando bene, ma quando ho preso nuovo progetto improvvisamente sta mostrando errore nel mio appcompat e nel mio progetto in percorso di generazione in Android dipendenza sta mostrando error.Pleas darmi qualche soluzione che cosa devo fare . e anche darmi più chiarezza di dipendenza Android e appcompat file di libreria . sta mostrando questo errore : -

appcompat_v7/res/values-v21/themes_base.xml:194: error: Error: No resource found that matches the given name: attr 'android:colorControlActivated'.
appcompat_v7/res/values-v21/themes_base.xml:195: error: Error: No resource found that matches the given name: attr 'android:colorControlHighlight'.
appcompat_v7/res/values-v21/themes_base.xml:193: error: Error: No resource found that matches the given name: attr 'android:colorControlNormal'.
appcompat_v7/res/values-v21/themes_base.xml:190: error: Error: No resource found that matches the given name: attr 'android:colorPrimary'.
appcompat_v7/res/values-v21/themes_base.xml:191: error: Error: No resource found that matches the given name: attr 'android:colorPrimaryDark'.

thanks

---

Top 5 Risposta

1user3173628 @

non avete aggiunto la libreria appcompat_v7 correttamente

controllare se avete la libreria in Fare clic con il Progetto- > proprietà- > selezionare Android- > appcompact lib ( questa biblioteca deve essere riferito non trovi questo) Quindi seguire questi passaggi : -

1 ) Fare clic con il progetto e selezionare Proprietà .

2 ) Nel pannello categoria sul lato sinistro della finestra di dialogo, selezionare Android .

3 ) Nel riquadro Libreria, fare clic sul pulsante Aggiungi .

4 ) Selezionare il progetto biblioteca e fare clic su OK . Ad esempio, il progetto appcompat dovrebbe essere elencato come android -support - v7 - appcompat .

5 ) Nella finestra delle proprietà, fare clic su OK .

Se non si vede nulla quando si fa clic sul pulsante Aggiungi ( punto 3 ), allora si dovrebbe consultare questo link: - https://developer.android.com/tools/support-library/setup.html, in quel link lettura aggiungendo biblioteche con risorse e il seguito delle operazioni .

OR

Make sure you have downloaded the Android Support Library using the SDK Manager.
Create a library project and ensure the required JAR files are included in the project's build path:
   1) Select File > Import.

    2)Select Existing Android Code Into Workspace and click Next.
    Browse to the SDK installation directory and then to the Support Library folder. 
    For example, if you are adding the appcompat project, 
    browse to <sdk>/extras/android/support/v7/appcompat/.

    3)Click Finish to import the project. For the v7 appcompat project,
   you should now see a new project titled android-support-v7-appcompat.

   4)  In the new library project, expand the libs/ folder,
   right-click each .jar file and select Build Path > Add to Build Path. 
   For example, when creating the the v7 appcompat project, 
   add both the android-support-v4.jar and android-support-v7-appcompat.jar files to the build path.
   5) Right-click the library project folder and select Build Path > Configure Build  Path.

    6) In the Order and Export tab, check the .jar files you just added to the build path, so they are available to projects that depend on this library project. For example, the appcompat project requires you to export both the android-support-v4.jar and android-support-v7-appcompat.jar files.
    Uncheck Android Dependencies.
   7) Click OK to complete the changes.
2Rohit Bandil @

infine il mio errore solveed ma non è la soluzione esatta quello che volevo . quello che ho fatto ho creato un nuovo progetto e ha preso la versione SDK minimo è 15 bcoz caratteristica barra azioni è presente in 15 e in seguito api .i pensare che funzionalità introdotta in 11 api .so ho preso nuovo progetto con la versione SDK min e poi no necessità di appcompat biblioteca ora nessun errore è in arrivo ... ma ho risolto questo problema con una soluzione alternativa, ma voglio anche risposta della mia domanda .

3Naveed @

Sì questa cosa era venuta anche a me fin troppo giorni . Vai alle vostre proprietà del progetto e selezionare tale versione Android API che tutte le cose vengono scaricati con voi in SDK per esempio nel mio caso api 17 scelgo e in sdk ho tutto installato .  quando sto prendendo nuovo progetto Android appcompt sta mostrando un errore

Ho fatto anche una cosa in più in ( immagine ) in basso si può vedere la casella di controllo (Is Library) ho rimosso il appcompat_v7 refrence e fare clic su Applica .

Dopo questo everyting lavorare con me come fascino ..... Finalmente vengo al punto che