Google adt / supporto GWT per Eclipse 4.4 ( Luna )

? MTilsted @ | Original: StackOverFlow
---

Avere qualcuno ottiene la versione di Eclipse 4.4 per lavorare con ADT (sviluppo Android) e / o Google Web Toolkit ( GWT ) .

Sembra che i GWT / plugins ADT che fare non funziona con Eclipse 4.4, quindi c'è un posto segreto per scaricare le nuove versioni o devo continuare a utilizzare 4,3 - (

Edit : La ragione per cui ho pensato che ADT non funzionava era che la documentazione ( http://developer.android.com/sdk/installing/installing-adt.html ) dice che il plugin si chiama " ADT Plugin ", che non lo è .

---

Top 5 Risposta

1user3396807 @

For adt,

help - > Installa nuovo Software - >    https://dl-ssl.google.com/android/eclipse/ - > non selezionare tutto

( ha funzionato così per me) ho selezionato tutto tranne strumenti di sviluppo nativi ( immagino non hai bisogno di loro se debelop in java ) e sta lavorando bene per me .

2raywang @

beh ... il plugin GWT realtà non può funzionare con rilascio luna dal momento che ha una dipendenza bundle per eclissi core.runtime [ 3.8.0,3.10.0 ), qui, ")" significa che non comprende 3.10.0 wihich viene utilizzato in luna, tuttavia, può essere sbarazzarsi modificando il file del pacchetto OSGi e allora sarà funziona bene con luna, almeno per me, per ora .

1 scaricare l' ultimo aggiornamento sito di file zip da Google site plugin di Eclipse 2 scompattarlo 3 allora si avrà bisogno di modificare 2 file in primo luogo

un file META INF / manifesto OSGi incluso in un barattolo di nome * GDT * E42 ( scusate, dimenticare il nome completo, lo si può trovare quando si tenta di installare il plugin, luna si lamenterà che qualche pacchetto dep è mancato ), che si trova in plugins dir, basta cambiare core.runtime versione da 3.10.0 ) a 3.10.0 ]

un altro dovrebbe essere contents.jar ( forse artefatti . jar ), stesso sopra

Ora è possibile installare il plugin se hai già il RCP eclissi installato

Tuttavia, l'installazione sarà riuscita perché l' hashing MD5 viene modificato ,

infine, copiare il md5 atteso dialogo messaggio di errore per sostituire il vecchio valore md5 in artifacts.jar ( forse contents.jar )

ora reinstallare il plugin, dovrebbe funzionare per il momento

UPDATED:

forse si dovrebbe rimuovere il pacchetto - versione dal MANIFEST.MF a jar com.google.gdt.eclipse.platform.e42 e cambiare la versione a " 0.0.0 " da content.xml a content.jar

3MrTux @

Google ha appena rilasciato il suo SDK ufficiale per Eclipse Luna : https://developers.google.com/eclipse/docs/getting_started

4ojonugwa ochalifu @

Se si utilizza l'opzione Help----->Install New Software, è possibile incontrare questo messaggio di errore, proprio come ho fatto cercando di installare il plugin di Android .

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase. session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=). Error reading signed content. error in opening zip file

La mia soluzione era quella di passare attraverso Help-->Eclipse Marketplace e quindi cercare "Android" Selezionare il plugin dal risultato della ricerca e installarlo da lì .