Aggiornamento Eclipse con strumenti di sviluppo Android v . 23

? greywolf82 @ | Original: StackOverFlow
---

Ho aggiornato Eclipse con i nuovi strumenti SDK (Ap 23 ), ma ora quando Eclipse inizia ricevo l'errore :

Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore . La versione attuale è 22.6.3.v201404151837-1123206 . Aggiornare ADT alla versione più recente .

Nessun aggiornamento è stato trovato " Verifica aggiornamenti " . Se cerco " installare nuovo software", posso vedere la versione 23, ma non posso aggiornare a causa del seguente errore :

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

Dopo il download dell'ultima ADT dal sito web, sembra che ci sia un altro problema . Con strumenti SDK rev . 23 Proguard non è installato, la cartella SDK dir/tools/proguard manca e altri strumenti sono mancanti . Questa versione contiene diversi bug .

---

Top 5 Risposta

1Daniel Díaz @

UPDATE : Google ha rilasciato ADT v23.0.2 . Ciò ha risolto molti problemi di precedente versione ADT 23 .

Step-by-step:

Help -> Install New Software... For "Work with", select the Android source https://dl-ssl.google.com/android/eclipse Aggiornamento Eclipse con strumenti di sviluppo Android v . 23 Tick ADT v23.0 for installation, then click "Next" Eclipse will show "Install Remediation Page" since there is conflict with previous version. (If it does not, see below.) Select "Update my installation to be compatible with items being installed" to uninstall the old version and install the new one. After that, proceed with the usual steps Aggiornamento Eclipse con strumenti di sviluppo Android v . 23

Nota : Quando ho installato la nuova versione di ADT, non ho incluso la nuova versione del pacchetto " Android Development Tools Native " . Invece, ho installato il resto dei pacchetti, e poi installato " Android Development Tools nativi " . Per un motivo, se provo a installare tutti i nuovi pacchetti, tra cui " Android Development Tools Native ", l'installazione non riesce .

UPDATE : Se non c'è " pagina Remediation ", http://stackoverflow.com/a/9097282/755804 Ma c'è il rischio di disinstallazione eclipse sé .

2bluewhile @

Per me ha aiutato a eliminare Android 4.4W che è anche API 20 e potrebbe essere una delle cause del conflitto. Così solo installare Android 4.4W o Android L fino a quando non risolvere il problema .

E ( ancora una volta questo potrebbe essere solo per me) funziona solo in Android Studio non in Eclipse ...

3Rajat Sharma @

Ho fatto in seguito per risolvere un problema .

Vai a http://developer.android.com/sdk/installing/installing-adt.html e scaricare l'ultimo file ZIP ADT ( in fondo alla pagina ) .

Vai a Eclipse - > Aiuto - > Info su Eclipse - > Informazioni di installazione

Elimina Android DDM, Android Development Tools, Gerarchia Viewer, strumenti di sviluppo nativi, Traceview, ecc, versione 22.x .

Aiuto - > Install New Software - > Aggiungi - > Archivio - > Selezionare il file ZIP scaricato nel passaggio 1 .

Selezionare tutte le ultime versioni di tutti i 23 che ho cancellato al punto 3 e accettare il contratto di licenza .

Riavviare Eclipse, e fissa il mio problema .

4stevyhacker @

Su ADT bundle Eclipse ho dovuto disinstallare prima l'ADT e poi effettuando una nuova installazione . Per rimuovere il plugin ADT da Eclipse andare su Aiuto> Informazioni su Eclipse > Installazione Dettagli . Selezionare ADT plug-in, quindi fare clic su Disinstalla . Dopo l'installazione disinstallazione ADT da Aiuto > Installa il nuovo software .

5Biljana @

DO NOT DO THIS

Attenzione : Si prega di consultare i commenti sotto questa risposta . Questi passaggi hanno avuto un impatto negativo per molte persone .

Click Help / Install new software... Click on What is "already installed" (as in picture below) In the new window you can uninstall the old ADT (uninstall Android Development Tools, Android DDMS, Android Hierarchy Viewer, Android TraceView, Android Native Development Tools and Tracer for OpenGL ES) Restart Eclipse Then again click on Help / Install New Software Choose ADT... Install

Spero che aiuta !

Aggiornamento Eclipse con strumenti di sviluppo Android v . 23