Android Wear Progetto Gradle Sync non riesce

? Eliezer @ | Original: StackOverFlow
---

Ho creato un nuovo progetto in Android Studio 0.8, al fine di iniziare a integrare Android Wear in una delle mie applicazioni . Creo un nuovo progetto e includere il fattore di forma Wear, ma quando provo a sync ottengo :

Errore : Impossibile trovare una versione che soddisfa com.google.android.support:wearable:+ .     Necessario per :         win_control : usura : non specificato

EDIT : Ho suonato in giro con Gradle un po ', e ora ricevo questi errori :

Errore: Impossibile trovare : com.google.android.gms : play- servizi - indossabile : +     Open in Struttura del file di progetto dialogOpen

Errore : Impossibile trovare : com.google.android.support:wearable:+     Open in Struttura del file di progetto dialogOpen

---

Top 5 Risposta

1nickjm @

Aveva lo stesso problema . Aprite il vostro gestore di Android SDK, andare in Strumenti - > gestire aggiungere siti, e aggiungere la tua repo :

https://dl-ssl.google.com/android/repository/addon-play-services-5.xml

Ho finalmente trovato queste utili guide . Ci sono un sacco di link non funzionanti e cattive informazioni in giro, ma questi dovrebbero funzionare :

http://developer.android.com/preview/google-play-services-wear.html

then,

http://developer.android.com/training/wearables/apps/creating.html

Inoltre, ricontrollare il vostro gestore di Android SDK per essere sicuri di avere tutti gli aggiornamenti più recenti, così come Android repository supporto / librerie !

2CyberDandy @

Ho scoperto che, come di Android Studio 0.8.1, l'opzione " Manage Add - On Siti " è assente dal menu Strumenti . Nel caso in cui qualcun altro non riesce a trovare neanche, ecco come arrivare ad esso :

1 / Vai su Strumenti > Android > SDK Manager.

2 / Poi, una volta che il SDK Manager è aperto, nel menu in alto vai a Strumenti > Gestisci siti Add- On .

Ci si va, poi basta applicare quello che nickjm detto ( grazie per la punta btw, mi chiedevo che cosa stava succedendo con questo messaggio di errore ! ) .

3user3196061 @

Aggiunta l'add sul sito non ha funzionato per me . In Android SDK, ho aperto semplicemente in su : Strumenti-> Opzioni ...- > Abilita Tools Anteprima ( controllare) Poi ha avuto un aggiornamento per la roba di usura ... che io, ovviamente, aggiornato .

Questo ha permesso la libreria da riferimento il IDE .

4Sveinung Kval Bakken @

Se il gestore SDK non trova alcun aggiornamento per voi, ha aiutato per me per pulire la cartella m2repository sotto ~/.android/extras/google/ .

È possibile aggiungere manualmente il sito di aggiornamento utilizzando un editor di testo su ~/.android/repositories.cfg, che dovrebbe essere simile a questo:

### User Sources for Android SDK Manager
#Wed Jul 02 10:15:39 EDT 2014
count=1
src00=https://dl-ssl.google.com/android/repository/addon-play-services-5.xml
5ekatz @

Se tutti questi non ha funzionato per voi, controllare le istruzioni a https://code.google.com/p/android/issues/detail?id=72454 Per me, ero semplicemente mancava Google Repository dalla sezione extra in manager sdk