Errore in ADT 23 Aggiornamento

? Gödel77 @ | Original: StackOverFlow
---

prima, so che è una domanda frequente, ma in modo che io sono qui dal momento che un paio di settimane non ho abbastanza fama di commentare in quei fili .

Beh, ho cercato di fare tutto ciò che in questi Question - fili, ma senza successo ( con https e senza, ADT23.zip scaricare troppo :( )

Questo è quello che ho avuto

Cannot complete the install because of a conflicting dependency.
  Software being installed: Android DDMS 23.0.0.1245622 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.0.1245622)
  Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
  Only one of the following can be installed at once: 
    Dalvik Debug Monitor Service 23.0.0.1245622 (com.android.ide.eclipse.ddms 23.0.0.1245622)
    Dalvik Debug Monitor Service 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms 22.6.2.v201403212031-1085508)
  Cannot satisfy dependency:
    From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508)
    To: com.android.ide.eclipse.ddms.feature.group 22.6.2
  Cannot satisfy dependency:
    From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
    To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508]
  Cannot satisfy dependency:
    From: Android DDMS 23.0.0.1245622 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.ddms [23.0.0.1245622]
  Cannot satisfy dependency:
    From: Android DDMS 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms.feature.group 22.6.2.v201403212031-1085508)
    To: com.android.ide.eclipse.ddms [22.6.2.v201403212031-1085508]

Come posso risolverlo ?

Thanks

---

Top 5 Risposta

1Jitu @

Era di fronte lo stesso problema, risolto disinstallando la versione precedente di ADT completamente e quindi installare la nuova versione .

Try it out.

2user3775520 @

Funziona per me :)

Se per qualche motivo si è installato un anteprima ADT e la necessità di ripristinare la corrente stabile, non è possibile utilizzare la finestra di dialogo per l'installazione " nuovo " software in quanto ciò che si desidera è in realtà una vecchia. Invece fare questo :

Open Help > About Eclipse... on Windows or Linux. On Mac, use the app's menu > About... Click the "Installation Details" button. Select the "Installation History" tab. Select one of the previous configurations. Click the "Revert" button at the bottom.

Errore in ADT 23 Aggiornamento

3Ingo @

È necessario aggiornare il vostro Google ADT per la versione più recente !

In Eclipse selezionare?

Installare nuovo software --- > Aggiungi

all'interno Aggiungere write Repository :

https://dl-ssl.google.com/android/eclipse/

Fare doppio clic in apertura Box voce 1 .

Seguire le istruzioni Eclipse .

Dopo aver caricato un po ' di tempo si ottengono i nuovi strumenti per gli sviluppatori e NDK Plugin

Ripetete l'operazione per 2 volte

Tom

4sibel_aflazi @

Stavo usando Eclipse Luna . Ho scaricato SDK 23. Poi, quando ho letto ADT 23 rilasciato ero emozionato . Ho scaricato troppo . Ma io relised ha molti errori . Non ho potuto fare nulla con eclissi . Ho pensato che l'altro, ADT 22 era buona .

Così ho iniziato a usare di nuovo Keplero . Installo SDK 22.6.2 e 22.6.2 ADT troppo . Sono felice ora . Io ho più nessun errore .

Se è in esecuzione, non toccarlo !

5SeekingAlpha @

Ho scaricato Eclipse Luna senza ADT . Questo è importante .

A seconda di dove è stato salvato il lavoro e quale versione di Eclipse che si stava utilizzando prima un pop up potrebbe venire dicendo che migreranno a Eclipse Luna ETC2 . Ho scelto di migrare a Luna .

Allora sono andato ad aiutare - > installare nuovo software e aggiunto il plugin ADT via https://dl-ssl.google.com/android/eclipse .

Ho eseguito la mia app stavo sviluppando sul ADT 22.xx e funziona benissimo sull'emulatore e il mio Nexus 5 .

Spero che questo aiuta .....