Android Studio dice di usare Gradle 1,10 - ma nuove versioni 1.12 ?

? KickingLettuce @ | Original: StackOverFlow
---

The error:

The project is using an unsupported version of Gradle.  Please use version 1.10.


My `gradle.build` file says this:

dependencies {
      classpath 'com.android.tools.build:gradle:0.12.+'
}

Per quanto ne so, la linea di cui sopra è corretto . Il mio file gradle-wrapper, dice :

distributionUrl=http://services.gradle.org/distributions/gradle-1.12-all.zip

Ciò è accaduto quando ho scaricato la nuova versione beta di Android Studio ( v.8 ) e ho cercato di importare un app che era, quello che presumo sia una vecchia versione di Gradle .

Inoltre, quando ho colpito " Fix Gradle Wrapper and re-import project ", non succede nulla .

---

Top 5 Risposta

1The Metal Beard @

C'è una differenza tra la versione Gradle e la versione Android Gradle Plugin ( 0,12 . + ) . Sembra che avete bisogno Gradle versione 1.10, non credo che le versioni successive sono supperted dal plugin Gradle Android ancora . Comunque, credo che fare in modo di utilizzare Gradle versione 1.10 sarà risolvere il problema .

2The End @

Se si desidera cambiare il Gradle -wrapper a una versione inferiore dovete cambiare distributionUrl a

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

ed eseguire nuovamente l'operazione involucro . Se questo non è sufficiente eliminare le cartelle .gradle e gradle ei file gradlew e gradlew.bat . Il wrapper replica e si scarica gralde 1.10

Dal Gradle aveva alcuni grandi cambiamenti api a partire dalla versione 1.10 e 1.12 non si può costruire un progetto con una versione superiore quindi i plugin sono costruire con . Quindi, se il plugin Android è costruito con Gradle 1.10 è necessario utilizzare la stessa versione