Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore

? Kalpesh @ | Original: StackOverFlow
---

Ottengo il seguente errore quando inizio la mia Eclipse .

Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore

E quando cerco di aggiornare da Aiuto > Install New Software ... utilizzando il link update eclissi https://dl-ssl.google.com/eclipse/plugin/4.2

Mi dà seguente errore :

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
Software currently installed: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
Only one of the following can be installed at once: 
ADT XML Overlay 23.0.1.1256982 (overlay.com.android.ide.eclipse.adt.overlay 23.0.1.1256982)
ADT XML Overlay 22.6.3.v201404151837-1123206 (overlay.com.android.ide.eclipse.adt.overlay 22.6.3.v201404151837-1123206)
Cannot satisfy dependency:
From: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
To: overlay.com.android.ide.eclipse.adt.overlay [23.0.1.1256982]
Cannot satisfy dependency:
From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
To: overlay.com.android.ide.eclipse.adt.overlay [22.6.3.v201404151837-1123206]

Cosa devo fare ora ?

---

Top 5 Risposta

1Dhawal Sodha Parmar @

Non c'è bisogno di fare qualsiasi cosa ,

basta scaricare nuova eclissi, installazione ADT 23.0.0 dal basso legame

https://dl-ssl.google.com/android/eclipse/

il problema risolvere ...

il suo successo perché avete SDK 23.0.1 e 23.0.1 ADT aggiornamento non disponibile ....

yesterday i have same issue, i have solved that.. 2user285oo6 @

Come avete fatto l'aggiornamento di SDK 23,0 senza aggiornare l' ADT mostrerà questo errore tipo come lei ha detto nella schermata .

Basta aggiornare il SDK di 23.0 è di alcuna utilità e fino a meno si aggiorna anche lo strumento di sviluppo correlato in ADT .

Seguire i passaggi

First delete the SDK 23.0 and update the ADT to 23.0 For doing the update you need to click on Install new software from help and choose the ADT/ https://dl-ssl.google.com/android/eclipse/ under the link upon which you get the new Development tools to update click all >next to continue . Upon successful completion you can now update the SDK to 23.0.

Nota : - Molti di coloro che hanno cercato di aggiornare il SDK hanno affrontare un problema non può completare l'installazione a causa della dipendenza di conflitto  Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore

Quindi è meglio bastone appena a 22.6v del ADT . L'aggiornamento a 23,0 è pieno di bug e ci vorrà del tempo per correggere i bug

3Kikiwa @

Se si dispone di un conflitto con la versione precedente :

Select Help > Install New Software Click on already installed Select all Android software on version 22.* Click on Uninstall Work with: https://dl-ssl.google.com/android/eclipse/ Select Developer Tools and Next Next, Accept the license agreement and Finish.

EDIT : Questo trucco è probabilmente non più necessaria !

Cercate di aggiornare gli strumenti SDK per 23.0.2+ e costruire & amp; strumenti di piattaforma per Ap 20 prima .

4Kalpesh @

La migliore soluzione a questo è quello di scaricare un nuovo ADT da http://developer.android.com/sdk/index.html

5Joff @

Kalpesh NON cancellare SDK 23.0 rimuoverà la cartella " tools" e non sarà in grado di eseguire SDK Manager dopo che . Lo so perché ho ​​appena fatto . Bad suggerimento!

La soluzione da Kikiwa ha lavorato per me .