Uso 1.7 richiede la compilazione con Android 4.4 ( KitKat ) ; attualmente utilizzando API 14

? user3810543 @ | Original: StackOverFlow
---

Così ho recentemente cambiato l'obiettivo del mio progetto per Android 4.0. Ora ho quasi errori su ogni riga e l'errore "Uso 1.7 richiede la compilazione con Android 4.4 ( KitKat ) ; attualmente utilizzando API 14" sulla console . Quindi la mia domanda è, come faccio a cambiare questo per lavorare con api 14 e compilare ? grazie .

---

Top 5 Risposta

1Eran @

In Eclipse : Fare clic destro del progetto - > Proprietà - > dalla barra laterale, selezionare "Java Compiler " e quindi modificare il livello di conformità Compiler a 1.6

2Justin @

Non sono d'accordo con Eran, questo errore causa impostando Project build target per 4.0 ( API 14 ) . Se il cambiamento di Java 1.6, potrai non è possibile utilizzare Java stile 1.7 sode, per esempio: ArrayList myArrayList = new ArrayList<>(); .  Per risolvere questo problema, impostare il vostro obiettivo a 4,4 ( API 19 ) o superiore .