Cercando di aggiornare ADT - ricevere errore " dipendenze in conflitto "

? uj- @ | Original: StackOverFlow
---

Ho avuto una serie di problemi da quando ho cercato di importare un progetto Android .

La posizione del mio SDK non è stato impostato nelle preferenze ( anche se era stato prima e ADT stava lavorando benissimo ) . Quando provo a impostare il percorso della cartella sdk, si dice

Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore . La versione attuale è 22.6.2.v201403212031-1085508 . Aggiornare ADT alla versione più recente .   Così cerco di aggiornare Eclipse dal seguente come suggerito in un altro SO posto ( dal " Verifica aggiornamenti " continua a dirmi che non ci sono aggiornamenti disponibili :

Aiuto - > Installa il nuovo software - > p2repo - https://dl-ssl.google.com/android/eclipse/ - > Check strumenti di sviluppo - > Avanti          Ed è lì che ottengo il seguente errore :

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
Only one of the following can be installed at once: 
ADT CDT Integration 23.0.2.1259578 (com.android.ide.eclipse.ndk 23.0.2.1259578)
ADT CDT Integration 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ndk 22.6.2.v201403212031-1085508)
Cannot satisfy dependency:
From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk.feature.group 22.6.2

Cannot satisfy dependency:
From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508]

Cannot satisfy dependency: 
From: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
To: com.android.ide.eclipse.ndk [23.0.2.1259578]

Cannot satisfy dependency:
From: Android Native Development Tools 22.6.2.v201403212031-1085508  (com.android.ide.eclipse.ndk.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk [22.6.2.v201403212031-1085508]

Come posso ottenere con successo attorno a questi errori e aggiornare eclissi ?

---

Top 5 Risposta

1The_ehT @

Basta disinstallare attuale versione ADT è 22.6.2.v201403212031-1085508 andando a Guida > Dettagli installazione> software installato e quindi selezionare ADT ( vecchia versione ) > Fare clic su Disinstalla . Ora reinstallare ultima ADT . In questo modo, sono stato in grado di aggiornare ADT alla versione attuale, spero che aiuta . Nota : Questo non funziona su ADT - bundle.

2Lightshadow @

OGGI, ho ottenuto lo stesso errore, come si :

Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore . La versione attuale è 22.6.2.v201403212031-1085508 . Aggiornare ADT alla versione più recente .

YOUR MESSAGE:

Questo SDK Android richiede Android Developer Toolkit versione 23.0.0 o superiore . La versione attuale è 22.6.2.v201403212031-1085508 . Aggiornare ADT alla versione più recente .

Ho fissato in 5 minuti :

1 - assicurarsi di avere ancora il file zip ( me è " ADT- fascio -windows - x86_64-20140321 " )

2 - Copiare il contenuto del zip in cui si desidera che sia

3 E 'come 1,30 GB ( credo), quindi a seconda del computer potrebbe richiedere alcuni minuti

4 Una volta che è copiato, aprirlo .

5 - Andate nella cartella eclisse, quindi aprire l'applicazione eclissi ( si può anche pin alla barra delle applicazioni, se si utilizza un sacco )

Ho avuto questo problema un paio di volte, e questo funziona sempre per me .

3Lightshadow @

Per Sanjay Manohar :

In sostanza, quando si è scaricato eclisse, che era in un file zip . Avevi bisogno di estrarre i file in modo da utilizzare il suo contenuto. Il file che ho scaricato è stato chiamato " ADT - fascio -windows - x86_64-20140321 " e ho ottenuto da " https://developer.android.com/training/basics/firstapp/index.html " .

Se si utilizza eclissi, probabilmente avete il file zip in tuoi download, quindi non c'è bisogno di scaricare di nuovo .

Se fossi in te, farei un file chiamato " Android" e in esso inserire il file zip ( da utilizzare come backup futuro se si hanno problemi simili )

Vorrei anche creare una cartella denominata spazio di lavoro per tutti i miei progetti, e una cartella denominata ADT in cui vorrei estrarre il contenuto del file zip .

Questo sarebbe cartelle dentro " Android" :

-ADT ( - > Contiene i file estratti del file zip " ADT - fascio -windows - x86_64-20140321 " )

-workspace ( - > contiene i miei progetti )

-adt - fascio - finestre - x86_64-20140321 ( - > il file zip )

Ci scusiamo per la creazione di una nuova risposta, non ho la reputazione ...

4priya @

Disinstallare tutti i componenti in conflitto . Nel mio caso, Open- GL, DDMS, ADT etc sono stati in conflitto con l'aggiornamento . Così ho disinstallato tutti questi, con ..

Aiuto-> Informazioni su Eclipse SDK- > Installazione Dettagli- > selezionare il componente di uninstall- > disinstallazione

Poi aggiornare la ADT .

Aiuto-> Installa nuovo software- > Selezionare il sito di aggiornamento Adt ( https://dl-ssl.google.com/android/eclipse/ se non presente aggiungerlo ) in disponibili s siti / w . E aggiornare l' ADT .

5Ankit Sachan @

Basta selezionare ADT da Strumenti per sviluppatori discesa