Eclipse percorso Juno ADT plugin di NDK rimosso ?

? UnTraDe @ | Original: StackOverFlow
---

Non riesco a trovare l'opzione per impostare il percorso NDK su Eclipse Juno con il plugin ADT . ( Ho scaricato ieri l' ADT Bundle dal sito Android) .

Tutti dicono che dovrei trovare sotto Windows - > Preferenze - > Android - > NDK ma l'opzione NDK sotto Android semplicemente non esiste. Forse hanno cambiato la sua posizione nella versione recente ? Comunque io non riesco a trovare un modo per cambiare il percorso di NDK nel mio Eclipse .

Immagine :  Eclipse percorso Juno ADT plugin di NDK rimosso?

Mi sento come se mi manca qualcosa di veramente ovvio qui ...

---

Top 5 Risposta

1user1667823 @

è necessario reinstallare il ADT-23.0.4.zip ( Non dimenticare selezionare Strumenti Android Native Development ) ;  http://developer.android.com/sdk/installing/installing-adt.html#Troubleshooting .

You should:

Download ADT-23.0.4.zip. Just re-install. Restart. You will see Eclipse > Window > Android > NDK tag. 2Gabo @

Ho avuto lo stesso problema, non so perché, ma i problemi è con la versione Eclipse / Juno, quindi i download nella pagina eclissi del Kepler versión e installa la pluggin di adt, e tutto funziona bene .

3frihatt @

Ho affrontato lo stesso problema . Era fastidioso sprecare quelle poche ore, ma credo ho capito . Quello che ho fatto è stato ,

Afferrato il file com.android.ide.eclipse.ndk_22.3.0.v201310242005-887826.jar dalla vecchia installazione ADT ho avuto, che ha mostrato l'opzione NDK dalla cartella eclipseplugins .

Ribattezzato a com.android.ide.eclipse.ndk_23.0.2.1259578.jar .

Incollato in adt-bundle-windows-x86_64-20140702eclipseplugins

Riavviato Eclipse .

Hi NDK!

Spero che questo non causerà alcun problema in futuro !

4tryer3000 @

Risolvere il problema da installare " Strumenti di sviluppo "

Da Eclipse - > Aiuto - > Install New Software ... - >

selezionare : "Android Developer Tools Aggiornamento del sito - https://dl.google.com/android/eclipse/ "

deselezionare " Contatta tutti siti di aggiornamento durante l'installazione di trovare il software necessario " opzione

cercare ed installare " Developer Tools "

5tangobravo @

Ho avuto questo problema con l'ultima Eclipse Luna e il plugin ADT - si è scoperto, nonostante sia il CDT e Android Developer Tools Native plugin installati in Eclipse Luna che non funzionavano .

La causa era che stavo usando Apple Java 1.6 ( che è Java 6 ), e Luna "richiede " una Java VM 7 . Nessun allarme sono stati forniti però! Per risolverlo ho installato l'ultimo JDK di Oracle, e poi aggiornato il file eclipse.ini all'interno del fascio Eclipse.app, aggiungendo le 2 linee :

-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/bin/java

appena prima della linea che è -vmargs .

Poi, quando ho riavviato Eclipse, è stato correttamente utilizzato il CDT Eclipse -> Preferences... elencato alcune impostazioni C ++ che non erano in precedenza lì, e la sezione Android ha una voce NDK il permesso di specificare il percorso .