Analisi dei dati per Android L failed.Unsupported major.minor versione 51.0

? sasu @ | Original: StackOverFlow
---

Dopo l'installazione di ADT Plugin per Eclipse, ho provato a fare una nuova applicazione Ciao mondo Android .

Ma ho incontrato con il seguente errore quando ho provato ad aprire una nuova applicazione Android . Sto lavorando con JDK 7.0 e JRE 7.0 . Inizialmente ho lavorato con JDK 6.0, ma incontrato con lo stesso errore, quindi ho disinstallato e installato JDK 7.0 e cambiato le impostazioni di percorso, rispettivamente .

L'errore è chiaramente :

Caricamento dei dati per Android L (Anteprima ) ha riscontrato un problema . Analisi dei dati per Android L failed.Unsupported major.minor versione   51.0 .

I miei livelli di conformità vengono modificate anche a JDK solo 1,7 . E ho anche cambiato il mio rispetto a JRE 1.7 .

---

Top 5 Risposta

1Sree14 @

Si prega di verificare quanto segue.

Ensure that you have restarted your system after specifying the path name. You can look for the following icon on your eclipse's layout screen. !( http://i.stack.imgur.com/WoX58.png ) The "20" specifies the android version to use when rendering layouts. Change it and see. Last but not least review your ADT configurations. Hope this helps. 2AJP @

Si può "risolvere" ha disinstallato la L SDK Android utilizzando il Gestore Android SDK.

Non soddisfacenti .

Edit

Penso http://stackoverflow.com/a/24566948/539490 è efficace suggerendo la stessa cosa, ma senza la disinstallazione ( invece sufficiente selezionare la versione delle API che funziona davvero ) .

3Ligen Yao @

Controllare la versione JDK . Deve essere JDK1.7 . JDK 1.6 non funziona .

4tounaobun @

Basta eliminare le piattaforme Android L . Redirect alla directory Android SDK .

ADT- fascio - mac - x86_64-20140321 / sdk / piattaforme / android- L

eliminare la directory android -L e riavviare il eclissi .

5Haimanti @

A volte può essere solo perché il livello di conformità compilatore non è impostato correttamente nelle impostazioni Eclipse Java Compiler .

Vai a Eclipse Preferenze, sotto Java SEZIONE > andare a Compiler e quindi del livello di conformità JDK select 1.7