L' importazione android.support.v7 non può essere risolto

? chatfun @ | Original: StackOverFlow
---

Sono nuovo di Android . Attualmente, ho la adt-bundle-windows-x86-20131030.zip (Windows 32 bit ) installato - e hanno installato con successo l' Android SDK e Eclipse . Inoltre, ho aggiornato tutto il manager di Android SDK . Ora, sto lavorando in Android v - 4.4.2

Il mio progetto viene eseguito con successo, ma quando ho importare android.support.v7.app.ActionBarActivity; e import android.support.v7.app.ActionBar; il progetto non debug. Ottengo l'errore The Import android.support.v7 cannot be resolved

Ho cercato in Google e installato Android Support Library poi aggiunse: v7 nel mio progetto .

File->Import (android-sdkextrasandroidsupportv7). Choose "appcompat" Project-> properties->Android. In the section library "Add" and choose "appCompat"

Screenshot

L' importazione android.support.v7 non può essere risolto

Aggiunto con successo in appCompat, ma comunque sto ancora ottenendo l'errore .

---

Top 5 Risposta

1AlexFritz @

Vai al progetto nel navigatore, fate clic destro sulla proprietà .

Vai alla scheda percorso di generazione Java sulla sinistra .

Vai alla scheda librerie in alto .

Clicca aggiungere vasi esterni .

Vai alla cartella ADT Bundle, andare a sdk / extras / android / supporto / v7 / AppCompat / libs .

Selezionare il file android -support - v7 - appcompat.jar

Vai a ordinare e l'esportazione e selezionare la casella accanto al nuovo vaso .

Click ok.

2Adjie @

Nel mio caso, il progetto appcompat_v7 auto-generata è stato chiuso . Quindi, solo aprire quel progetto in Package Explorer .

Hope this help.

3JohannB @

Ho avuto lo stesso problema ogni volta che ho provato a creare un nuovo progetto, ma in base alla potenza della console, è stato a causa di due versioni di android -support- v4 che erano diverse :

[2014-10-29 16:31:57 - HeadphoneSplitter] Found 2 versions of android-support-v4.jar in the dependency list,
[2014-10-29 16:31:57 - HeadphoneSplitter] but not all the versions are identical (check is based on SHA-1 only at this time).
[2014-10-29 16:31:57 - HeadphoneSplitter] All versions of the libraries must be the same at this time.
[2014-10-29 16:31:57 - HeadphoneSplitter] Versions found are:
[2014-10-29 16:31:57 - HeadphoneSplitter] Path: C:Usersjbaurerworkspaceappcompat_v7libsandroid-support-v4.jar
[2014-10-29 16:31:57 - HeadphoneSplitter]   Length: 627582
[2014-10-29 16:31:57 - HeadphoneSplitter]   SHA-1: cb6883d96005bc85b3e868f204507ea5b4fa9bbf
[2014-10-29 16:31:57 - HeadphoneSplitter] Path: C:UsersjbaurerworkspaceHeadphoneSplitterlibsandroid-support-v4.jar
[2014-10-29 16:31:57 - HeadphoneSplitter]   Length: 758727
[2014-10-29 16:31:57 - HeadphoneSplitter]   SHA-1: efec67655f6db90757faa37201efcee2a9ec3507
[2014-10-29 16:31:57 - HeadphoneSplitter] Jar mismatch! Fix your dependencies

Non so molto di Eclipse . ma ho semplicemente cancellato la copia del file jar dalla cartella librerie del mio progetto in modo che avrebbe utilizzato il file jar appcompat_v7 invece . Questo risolto il mio problema .

4Elenasys @

Ho provato la risposta qui descritto ma Indifferente lavorato per me . Ho gli ultimi strumenti SDK Android ver . 23.0.2 e Android SDK Platform -tools ver . 20

La libreria di supporto android-support-v4.jar sta causando questo conflitto, basta eliminare la libreria nella cartella /libs del progetto, Non abbiate paura, la libreria è già contenuto nella libreria appcompat_v7, pulito e costruire il vostro progetto, e la vostra progetto funzionerà come un fascino !

L' importazione android.support.v7 non può essere risolto