Dopo l'aggiornamento - incidente com.google.android.gms : play- services : 5.2.8

? user3871754 @ | Original: StackOverFlow
---

le mie dipendenze :

compile "com.android.support:appcompat-v7:20.+"
compile 'com.google.android.gms:play-services:5.2.08'
compile 'com.android.support:support-v4:21.0.+'

ma ancora : Google Play servizi aggiornati. Richiede 5208000 ma ha trovato 5089036

come è possibile ?

AGGIORNARE questo lavoro :

compile 'com.google.android.gms:play-services:5.0.89'

or

compile 'com.google.android.gms:play-services:6.1.11'

or

compile 'com.google.android.gms:play-services:6.+'

---

Top 5 Risposta

1Michele @

È necessario aggiornare Google Play Services dal Play Store sul tuo dispositivo, se non si vede alcun aggiornamento aspettare fino esce

https://play.google.com/store/apps/details?id=com.google.android.gms

In alternativa, cercare su Google e installato il nuovo apk o utilizzare una versione precedente come 5.0.77 o 5.0.89

2Jerome Campbell @

Cambia il Google Play versione Servizio in build.gradle alla versione del dispositivo o un emulatore .

compile 'com.google.android.gms:play-services:5.0.89' 
3josacky @

La versione che si sta cercando è 5.2.08 .

Android Studio offrirà automaticamente di aggiornare alla nuova versione . Tuttavia, a causa di un bug, cade lo zero in " 08", il che significa che sostituisce la dipendenza con " 5.2.8 " invece di " 5.2.08 " che non funziona . Per risolvere questo problema, modificare la dipendenza di leggere " 5.2.08 " invece di " 5.2.8 "

This will work:

compile 'com.google.android.gms:play-services:5.2.08'

fonte : http://tools.android.com/knownissues

4jQwierdy @

Per le persone che soffrono di questo problema, ma non sono in grado di fare altri lavori - il mio problema è che ho installato Google Play 5.2.08 nel mio file Gradle ( compila ' com.google.android.gms : play- servizi : 5.2.08 ' ) perché 5.0.77 non funzionava .

Ho caricato l' app sul mio telefono e non ha funzionato ,

Ho avuto l'ultimo aggiornamento ( che avrei potuto ottenere sul mio telefono - 4.4.2 Android ) di Google Play in modo che mi dice di aggiornare non mi ha dato tutte le opzioni

Ho finito solo bisogno di aggiornare il mio file Gradle all'ultima GooglePlay compatibile, nel mio caso la versione 5.0.89 . Così scoprire quale versione

5friederbluemle @

You can now use

compile 'com.google.android.gms:play-services:6.1.11'